[SOLVED] Inclusion issue with zwave_js add-on 0.61, fixed in 0.62

Hi all, second question now that I am ramping up moving my devices from smartthings to HA.

I have paired up 9 z-wave devices without issue. First excluding them from smartthings then adding to HA. The last device was a schlage camelot lock. I spent time after getting keymaster set up for a while.

I went to add another device, excluded it and then tried to pair it with HA and the device was not found. I tried 5 other devices and it won’t find any of them. I had no issue pairing them back up with smartthings afterwards.

I am at a loss on understanding why or what to do next. I don’t find any similar reports searching?!

What kind of devices? Powered? Battery?

I have about 40 of the Jasco/GE/Enbrighten On/Off, Dimmer and fan control switches as well as a few in wall outlets and wall wart outlets. I have paired 8 switches and then the camelot lock was my last which is battery operated.

What I have been trying to pair since the lock are the in wall light switches/dimmers, 5 of them now.

I did note that right before I added the schlage camelot lock there was a zwave js update that I let it perform before connecting the lock yesterday.

How close to the controller are these devices? Also, make sure you USB stick is on a 3’+ USB extension cable. (reduces noise)

So the lock is about 25 feet away and paired just fine. The light switches are about 3 feet from the lock and simply don’t show when pairing is started. I then tried some switches about 5 feet from the RPI and same failed results, It just times out waiting for a device to be discovered.

I have run both the “exclude” from smart things repeatedly and performed the keypress sequence to reset on multiple switches, both of which indicate success before trying to pair with HA.

I power cycled the RPI twice. The believe the only other zwave devices I have are my garage door opener and the front door lock which I may try when I get home from work today.

I did edit the above post to mention that there was a zwave js update in HA that I performed just before adding the lock yesterday.

Oh and I have the nordtek zwave/zigbee USB dongle, no extension ATM but I dont see how that is the issue when I am 5 feet from it with no success.

It is an issue, 100%. It may not be the cause of your inclusion issue, but it is an issue.

Next step is to turn on logging, and see what is going on here.

Have you tried disconnecting the stick from the Pi and reconnect it? Maybe something stuck somewhere.

I assume you mean disconnect/reconnect while its on?

I have power cycled it but not pulled the device while on.

I can look at getting an extension, I just don’t see that as my problem today given everything else paired without issue up to and including a battery operated lock. An hour after the lock was paired nothing shows up anymore?

Ok so pulling the usb dongle while connected was no good. Going to blow away the zwave devices and integration and start from scratch while im only looking at a few devices to pair again.

Get the extension its a known issue. It may be once you get to a certain level of zwave traffic is starts manifesting.

It seems to be my Nortek device. I wind up with “NodeXX” that is not completely installed when I pair etc… I even wiped out HA completely wiped the SD Card. I just can’t “Wipe” the nortek stick. Exported my node red work and a list of what I had added. Been running this thing for a month before finally getting around to setting it up all the way and this is what happens.


I just discovered this issue last night. A more permanent fix will be added to the driver in the future but I will push an update to the addon that resolves this issue soon. Sorry for the inconvenience

1 Like

Is this a problem with the new zwave update that I installed right around the time I started having this issue?

Yes, it’s an issue with the version of zwave-js that we updated to along with the update to zwave-js-server. It looks like I was too aggressive adding support for a new feature because it wasn’t fully baked yet, but that wasn’t known until we pushed this update.

Lol ok thanks. My timing as ever is impeccable. Just started transitioning about 50 zwave devices this week from ST when I hit this.

1 Like

Murphy’s law and all I guess? Sorry, I had to make a transition like that too in the past so I can appreciate how annoying this is. Fix is in place, new server version released, just testing this specific issue in the addon before I release it

Understood. At least I was just at the beginning. I’m more relieved it isnt a problem with the Nortek stick.

the new addon has been released

1 Like

Do you mind changing the subject to “[SOLVED] Inclusion issue with zwave_js add-on 0.61, fixed in 0.62”? it will hopefully prevent dupe topics from being opened up

1 Like