[solved - info] Fritzbox device tracker confusion with multiple Fritz devices in network

Tags: #<Tag:0x00007fc40a857660>

Hi everyone,

I thought I’d share the following experience that drove me nuts over the last few weeks, along with my solution. Hope it helps someone.

I have the following Fritz devices on my home network:

  • Fritz!Box 7530, serves as the VDSL router and mesh controller (no Wifi enabled)
  • Fritz!Repeater DVB-C as the main Wifi access point, connected to 7530 over LAN
  • Fritz!Repeater 1750e as … a repeater that connects to the DVB-C repeater

All 3 devices are configured as a mesh. The “main” Firtz!Box 7530 as a mesh master sees each and every device on the network, their IP, status, the whole network topology etc. etc.

Switching from the old, custom HACS-based Fritz integration to the built-in, all 3 devices were auto discovered by Home Assistant. The conguration went seemingly well, too, using user and password pairs (for the DVB-C repeater which does not have multiple users, “admin” worked)

However, when I looked at the device trackers that the 7530 had discovered, I could only see a part of them - 51 our of a total of 150 entities (including network switches etc.). I particular, I couldn’t see any of the network devices that the 7530’s “network” overview showed as bein online - only old, not active entries from the 7530 were visible. And all of the “unavailable” or “away”

Some of the devices connected via Wifi to the 1750e or DVB-C were visible as device trackers in their integrations, but the overall picture excluded a lot of devices - especially the ones that were connected with LAN cables. None of them showed up.

Turns out there was a conflict between the 3 Fritz integrations. Maybe there were some conflicting UIDs - I haven’t found a final explanation yet. But trial and error gave me the following solution:

  1. Delete all Fritz integrations via the user interface (yes, delete them, not just disable)
  2. Restart HA, Fritz devices should be discovered
  3. Configure your Mesh Master, using User / Password credentials as usual
  4. “Ignore” the other Fritz integrations that the discovery has found. Again, do not set them up and the disable them - “ignore” them right from the start

At least, that helped me.