[solved - ISP related] External access (hassio / DuckDNS) stopped working. Cert date still valid

Annoyingly my external access stopped while I was away. I get variations of:

This site can’t be reached
The web page at … might be temporarily down or it may have moved permanently to a new web address.

(depending on what browser / device I try from)

I’ve checked that the IP address the DuckDNS site goes to matches my externally facing IP address.

It doesn’t look like my certificate has expired, as the log indicates it’s good until August. I have been able to get in with local IP address and telling my browser to ignore the certificate errors, though the browser does confirm the certificate time period is till valid. My log doesn’t show anything of interest, in fact nothing at all except repeated warnings about updating ring sensor taking too long.

I was on DuckDNS 1.3, and have just updated it to 1.4 but no difference.
I’m on HA 0.69.

Can anyone suggest how I can find some more info to troubleshoot?

Mine keeps throwing a wobbly on 0.71, I’m fairly sure it was ok on 0.69 though.

After an as yet undetermined time Alexa via Haaska starts giving unresponsive errors. If I go into the hassio duckdns tab and hit restart all is good again until the next time.

Restart reverse proxy server if you have one.
Clear web browser cache.

Thanks for replies.

I get this on multiple devices and browsers, and browser cache reloads hasn’t worked on any of them. I don’t have a reverse proxy.

I have now upgraded to .71, but this has made no difference. I’ve also done a hard reboot of my Raspberry Pi, and tried a restart of DuckDNS but still no joy. I’ve also rebooted my router and broadband antenna (I have wireless community broadband).

I did have this same problem a month or so ago, and ended up completely uninstalling and re-installing DuckDNS from scratch to get it working again, but I can’t really do that every few weeks!

Try access from WAN IP directly to confirm outside connection OK.

Good call - that does seem to be the issue. Tried that and got ERR_CONNECTION_REFUSED.

I’m not sure I understand what might have happened. Just double-checked my router and the port is still forwarded. I’m a bit stumped now.

Out of interest I found a website that does a port scan of common ports. I put my external facing IP in and was surprised to see ssh/22 open:

21/tcp   closed   ftp
22/tcp   open     tcpwrapped
23/tcp   filtered telnet
80/tcp   closed   http
110/tcp  closed   pop3
143/tcp  closed   imap
443/tcp  closed   https
3389/tcp closed   ms-wbt-server

My router (ASUS) has port 22 enabled as “LAN only”, and I don’t have it port forwarded, so now I’m mighty confused (and a little concerned). Is this something I should talk to my ISP about?

Thanks for any more help, though I realise it looks like the issue probably lies outside of Home Assistant / HASSIO now! I’m not particularly strong on network stuff, so grateful for any suggestions on where to look for answers to this!

I am having this exact same problem after updating DuckDNS addon to 1.4. I have removed all components from my config to confirm there is no component conflict. I can also get local access. Tried everything I can think of.

Woohoo! I’m sorted!

I’m afraid this is probably a pretty niche case so unlikely to be much help for others, but my issue was indeed ISP related. I’ve just been on the phone to them, and they said because of the shortage of public IP addresses, customers can get allocated a shared IP address (not sure how that works), and that’s what had happened to me. They have a way of ensuring specific customers are always allocated a dedicated (though not static without paying more) IP address though. I’ve now been added to that list (a new list as I’m the first person in my area to phone them about this apparently), and now I’m up and running again.

Thanks for the help!