[SOLVED] Issues with MOES UFO-R11

I am trying to setup the IR blaster but everytime it learns a code and I try to play the code back, it doesn’t work. I can confirm in my logs that the payload is sent.

Here are the logs for debug Debug 2024-04-19 10:28:32Starting IR Code Learning...Debug 2024-04-19 10:28:32 - Pastebin.com

What I’ve tried:

  1. Resetting the IR blaster
  2. Restarting zigbee2mqtt and HA containers.
  3. Sending code via scripts and zigbee2mqtt UI
  4. Placing the blaster nearer to a/c and away.
  5. Hiding the blaster away from any light
  6. Using an old IR blaster (using tuya) to send the code.

I have verified:

  1. Communications between zigbee2mqtt - HA is working fine, got the name and payloads correct

I couldn’t find any publicly available IR codes for this a/c which is a mitsubishi starmex. If anyone has details and willing to share please let me know!


Honestly, no proper solution. I just kept moving my IR around, and I reinstalled the batteries. I noticed a difference, now when it sends the code, it sends as a sequence. Perhaps someone can understand this better than I do.

RC: Infrared Hex Code Database: Mitsubishi Air Conditioning Commands (Page 1).

Are you sure the AC requires simple codes (like a TV, for example)? A lot of people seem to have trouble with AC, and it sounds as if it needs codes to be sent multiple times.

Oh yea I saw this too, but it didn’t work or couldn’t figure out how it works.

But yes I did hear about people having multiple issues and needing an arduino to decode it or something