[SOLVED] Lets Encrypt Certificate Invalid (Not using Duck DNS)

I wonder if someone could help me, i am having major problems with my Lets Encrypt certificate.

It was working fine the first time i used it but since the first renewal it has not worked since.

I am not sure whether its because of the system updates of my HASS.IO install or whether its because i have a config error but either way its a pain as i cant use the HA app on my devices because of the invlaid cert.

Lets Encrypt Config

  "email": "[email protected]",
  "domains": [
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem"


Uncomment this if you are using SSL/TLS, running in Docker container, etc.


base_url: example.duckdns.org:8123

base_url: https://ha.domain.com
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

Any help would be appreciated.

Do you have port 80-80 forwarded in your router?

Port 80, 443 and 8123 … however will do a can u see me port check

all ports definitely open and can be seen

What is the date of your certificate file

ls -l /path/to/file

And below is the contents of the log file wehne Lets Encrypt is run

Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /data/letsencrypt/renewal/vintnet.com.conf

Cert not yet due for renewal

The following certs are not due for renewal yet:
/data/letsencrypt/live/domain.com/fullchain.pem expires on 2019-08-23 (skipped)
No renewals were attempted.

Posting your config properly may reveal something.

I ended up just buying a certificate and using that instead of Lets Encrypt.

At least i know that this issue dealt with for the next 2 years