Solved :Letsencrypt , duckdns on Synology docker

I migrated hassio on RPI to Hassbian on Synology Docker.
Everything works fine but to secure homeassistant on Synology I followed the instructions found here :

I can access home assistant with https: … but I get the message it is not a secure connection.

When I try to access homeassistant on my RPI (same url…different port) I don’t get this message. On my RPI I used the Duckdns-addon.

Do I have to add something to my config on Synology ?

In hass on my RPI i have these lines in config.yaml

  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem

When I put these lines on my Synology configuration I get this error :

Invalid config for [http]: not a file for dictionary value @ data['http']['ssl_certificate']. Got '/ssl/fullchain.pem'
not a file for dictionary value @ data['http']['ssl_key']. Got '/ssl/privkey.pem'. (See /config/configuration.yaml, line 95). Please check the docs at

I am sure I have to do somethinhg else, but don’t know what.
Do i have to put a certificate somewhere, and how do I get that ?

Solved : What I did not new I had to add in DSM-certificate that the certificate was provided by Letsencrypt.
Synology automatically filled in it was provided by Synology

How did you add/change the DSM cert? From terminal or the GUI? I am having the same problem.

I added it from the GUI