[SOLVED] Migration from Raspbian install to Hass.IO and having issues with reverse proxy and MQTT switch states after reboot

Prior to this evening, I was running Home Assistant on a Raspberry Pi 3B+ using the Raspbian installation method. I set up reverse proxy for Apache, and all was good.

Tonight, I set up a brand new Raspberry Pi 4, and installed the Hass.io image on a new MicroSD card and booted it up. I went into my Tasmota devices and reconfigured their MQTT settings to use to point to the new server. I created new rules, and tested them all. They all seemed to work,

I then went into my Apache server and modified my Apache config. I took the exiting configuration and just replaced the IP address of the old server with the new server. I restarted apache and tried to connect to the external DNS name of my server. And it was painfully slow. It eventually loads, but it takes MINUTES for the page to load instead of seconds.

This is my Apache config:

<VirtualHost *:443>                                                                                           
ServerName home.server.net                                                                               ProxyPreserveHost On
ProxyRequests off                                                                                                                                                                                                       ProxyPass /api/websocket ws://                                               ProxyPassReverse /api/websocket ws://                                                                                                                                                    ProxyPass /                                                                       ProxyPassReverse /                                                                                                                                                                            RewriteEngine on                                                                                            RewriteCond %{HTTP:Upgrade} =websocket [NC]                                                                 RewriteRule /(.*)  ws://$1 [P,L]                                                          RewriteCond %{HTTP:Upgrade} !=websocket [NC]                                                                RewriteRule /(.*)$1 [P,L]                                                      Include /etc/letsencrypt/options-ssl-apache.conf                                                            SSLCertificateFile /etc/letsencrypt/live/home.server.net/fullchain.pem                                   SSLCertificateKeyFile /etc/letsencrypt/live/home.server.net/privkey.pem                                  </VirtualHost> 

The other issue I am having is that when I restart Hass.io, all of my switches show up as off in hass.io.

Any help greatly appreciated.

Ok, woke up this morning and decided to give it a fresh look, and everything seems to be working now. I didn’t change anything between 3:00 AM when I went to bed and 10:00 AM this morning when I work up. But I’ll go with it!