(SOLVED) NEW Sonoff T1 R2 EU2C - Can't get into flash mode for Tasmota

A couple of weeks ago I programmed a couple of sonoff T1 2 channels with tasmota as per the tasmota wiki - no problems

Just got 7 more (Banggood via china - same supplier) T1 2C’s and cannot get them into flash mode what ever I do !!
I first checked that all worked using sonoff ewelink and even updated one to see if they can be reprogrammed 2.7.1V - fine.

Have tried the wiki - power up/press touch button 1/press reset button/release touch button 1 - wifi led keeps flashing - original ewelink program still running

Tried shorting R19 to ground - same as touch 1 - no go
Tried powering up with various buttons pressed/shorts - no go
Always get WIFI led on or flashing.

Tried using termite to see it the sonoff goes into flash mode but get junk - tried 9600/74880/115200
Hex view below
78 00 78 00 c3 78 1e 7f 3c 0f 3c fe 80 78 1e 87 x.x.Ãx.<.<þ€x.‡
00 78 e0 80 78 00 03 e0 78 1e ff 80 f8 f8 78 fe .xà€x…àx.ÿ€øøxþ
78 fe 78 fe f8 00 xþxþø.
Same junk if I use Putty - maybe its Chinese

Tried using 2 different USB TTL adapters - they worked for my other sonoffs (Basic/Dual/Power/Orig T1)
Measured the voltage rails 3.1-3.2V so even provided another 3.3V supply (Breadboard PSU - common OV)

New board layout/version numbers match the 2 I got before

Any thoughts ?


Hi, I recently went through the same saga.
I had a sonoff T1 R2 US which I couldn’t flash: I tried 3 different usb serial adapter plus a raspebby but nothing.
Using putty simply realized the esp8266 was not booting in flash mode.

ESP 8266 though will boot in flash mode if you ground GPIO0 for like 5s while powering this wherever it is installed.
I used a tiny wire to ground it to the sonoff T1 ground pin: after 5-6 times it worked.

Hi mspinolo

I found some recent info on the tasmota git hub site this morning which backs up what you are saying - so as I’m typing this I’m reprogramming the 7 T1’s
Its a bit hit/miss but linking R19 (GPIO0) to ground and plugin the USB lead in is the only way it works.

Thanks for the help