[Solved] No configuration check on 0.96.0b2 and core configurator not helping

I am running latest docker version of hassio/ha etc on a arm 64 board

arch aarch64
dev false
docker true
hassio true
os_name Linux
python_version 3.7.4
timezone America/Vancouver
version 0.96.0b2
virtualenv false

I suppose something has changed because the configuration check button at /config/core is missing/gone.

So I loaded via hassio the addon core configurator ( now version 2.2). It takes forever to parse and evaluate and then the log does not indicate anything wrong although clearly I have an automation that has an issue as indicated by a notification.

Can someone illuminate how to get my configuration checked with this version. I’m running blind with no check/log of my configuration and thus can’t really keep developing.

for example this automation is not showing up in the states so I assume it has an issue

  - alias: test_timer_countdown
    initial_state: false
    trigger:
      platform: time
      seconds: '/1'
    action:
      - service: variable.set_variable
        data:
         variable: test_timer
         value_template: '{{ [((variable.state | int) - 1), 0] | max }}'

but the core configurator log just shows this which is no help at all.

automation:
    - action: ?
        - data: [source /tmp/config/configs/automations.yaml:7]
            message: Update for Home Assistant is available.
          service: notify.martin
      alias: Update Available Notification
      hide_entity: False
      trigger: ?
        - platform: state
          entity_id: ?
            - updater.updater
    - action: ?
        - data_template: ?
            entity_id: Template("input_number.fan_on_temp")
            value: Template("{{ trigger.payload }}")
          service: input_number.set_value
      alias: Closet Fan On Set Temperature slider
      hide_entity: False
      trigger: ?
        - platform: mqtt
          encoding: utf-8
          topic: closet/status/fan/automation/temp
    - action: ?
        - data_template: ?
            payload: Template("{{ states('input_number.fan_on_temp') }}")
            retain: Template("True")
            topic: Template("closet/fan/automation/temp")
          service: mqtt.publish
      alias: Closet Fan Temp Slider Moved
      hide_entity: False
      trigger: ?
        - platform: state
          entity_id: ?
            - input_number.fan_on_temp
    - action: ?
        - data: [source /tmp/config/packages/timer.yaml:26]
            entity_id: automation.test_timer_countdown
          service: automation.turn_off
      alias: test_timer_trigger
      hide_entity: False
      trigger: ?
        - platform: state
          entity_id: ?
            - variable.test_timer
          to: 0
    - action: ?
        - entity_id: ?
            - script.zone_1_run
          service: script.turn_on
      alias: Trigger Zone 1 Run
      condition: ?
        - condition: and
          conditions: ?
            - condition: template
              value_template: Template("{{(as_timestamp(now()) | timestamp_custom("%A, %d %h %H:%M"))  ==  states.sensor.zone_1_next_run.state}}")
      hide_entity: False
      trigger: ?
        - platform: time_pattern
          minutes: /1

Turns out that particular issue I needed to use plattform: time_pattern. That’s great I figured it out (guessed) but the configuration check either “built in” or via the add on is no help. :-(.

Go to your user profile and enable advanced mode.

2 Likes

So simple!! Even though my user was the only andadmin user apparently this setting was turned off when this new version was installed.

Now @VDRainer just a little other suggestion. Any way to put that button at the top of that page? The location setting dialog appears before it so I must scroll down every time just to press this button.

Better yet is there a way to access or place this in a more convenient location for development?

Don’t ask me, i’m no developer. :slightly_smiling_face:
But there are multiple requests here and on github about the config check and restart buttons.
I’m sure there’s someting in progress. :crossed_fingers:

thanks! I was having the same issue, thanks for posting!

In the past I was in the same situation where advanced mode was turned off after an update.
Now (0.97 and also 0.97.1) with the advanced mode on it still does not show the config check button and restart buttons at the bottom of Configuration/General. I toggled a few times advanced mode off and on, but no change. Might there something be missing in configuration.yaml?

EDIT:
Found it! It was moved to separate section; Server control, right under General at Configuration page…

2 Likes

Thanx!! So stupid… I had the same problem… I thought is was a bug in the config, but apparently they moved it. :stuck_out_tongue_winking_eye: