[SOLVED] Node Red wont connect to Deconz Server


I might have the simplest and most stupid question of all, but I do not find what I do wrong.

I am trying to configure the deConz server within Node Red, as described in this video. However, whatever I try and find in the internet, I get the message: image
It does not matter that IP i put in. Going to brings me to the Deconz login page. So it should work…

Things I tried:

Everything gives me this response.

HI there, you have to use your IP of deconz ( as above) port and websocket port. Then authenticate 3rd party app in phoscon. Magic will work :slight_smile:

Thanks for the quick reply!
You mean like this? Does not work:(

Please, double check your IP address and port, for example, port specified above and in the print screen is not the same one. And second thing, are you sure about your websocket port?

Hi JayCee, my bad. I made a typo to show it quickly. With the typo restored it gives the same error. brings me to the gateway

PS: Editted the previous post with a new screenshot.

And your question about Websocket, I followed the default settings;

Same problem here :frowning: not able to connect using hassio in docker

Bump :slight_smile:

Did you add an API key or temporarily enable ‘timed’ access to deCONZ to acquire such a key ?
In my usage I manually added a valid key and that works

I opened deconz to connect 3.party apps yeah…

I left the API key empty and authorized third party apps indeed, and I tried with manual API input. For API I put the section with red. Fot this string from the logs of Deconz in Home Assistant.

Still get the same message. Like it doesn’t even try to connect.

It doesn’t matter what I put in that IP box. It always gives the answer; just give me your Home Assistant IP…

I’ve got it working…

  • Reset network config of Deconz addon. Then put in the websocket and port at network config. (8081 and 40850
  • Restart deconz and nodered addon’s several times.
  • Check Node Red log for
    [info] [deconz-server:deconz] WebSocket opened
    [info] [server:Home Assistant] WebSocket Connecting http://supervisor/core
    [info] [server:Home Assistant] WebSocket Connected to http://supervisor/core
  • If authentication does not work get the API from the Deconz Add-on logs. Looks like 8917T2XR5G <-- example!
  • save and restart addons a few times. Should work now.
1 Like

Thanks for the tips. I couldn’t make it work in any way. Even in manual mode I’ve got “No response from server” when tried to get the API password. Then I tried your tips 1 and 2, and after restart I just saw it in the deConz log file as "172.30.XX.XX - - [27/Apr/2020:18:59:39 -0500] “GET /api/BF67XXXX62/config?_=15880XXXX8293 HTTP/1.1” 200 2180 " where BF67XXXX62 is the API password.

Yes, yes yes… that worked! thanks for the tip to look for the logs in supervisor/addon for Deconz.