[SOLVED] Owntracks SSL/TLS Client Struggles

Hello !

So I’ve been a long time lurker, long time user of home assistant but recently decided to use mosquitto and owntracks device tracker to do some automations. I’ve got everything working without any issue really except for SSL/TLS with owntracks.

Couple things…

I have my certs generated and installed in mosquitto. Port 8883 forwarded and verified. My question is more related to the owntracks client though. Do I need to use client certs? I try private mqtt and private http and set TLS on, and auth, but i get errors like: Trust Anchor for certification path not found in the client status.

I’m very familiar with SSL and key pairs but not so much with TLS in general. Is there any guides that explain this thoroughly. I’ve not been able to find a comprehensive one with screenshots even for the Android and IOS clients.

I wanted to add that I can successfully connect MQTTBox when choosing CA Signed Server Certificate and use mqtt/tls as the type of connection from the outside.

Thank you for any assistance!

[SOLVED] So I went back and revisited this today and realized I didnt install the CA cert on the device. It seems to be connected Private MQTT over TLS now!


can you elaborate on installing the cert on the device? I have two smartphones using Private HTTP and one works and one gets the cert path not found error (it did work for a little while). Now I’m stumped on how to fix it. I followed a scenario where I copied the cert and key to a Home assistant TTS folder and updated config. (i’m running HASS on Qnap in docker so securing external access via https://[name].myqnapcloud.com:8123) Any of that make sense? Any help is appreciated.