[Solved] Params of Tuya socket: OK in zigbee2mqtt but strange in HA


I am experimenting w/ Home Assistant and Zigbee. I currently have 2 Zigbee devices. A temperature sensor (Sonoff) and a socket (Nous A1Z which is detected by zigbee2mqtt as TS011F_plug_1.

I observe (in the frontend of zigbee2mqtt and after several pairing attempts) that the socket seems to be correctly detected; in read + “write” (i.e. send commands) mode.

However, in Home Assistant, only some features are available. E.g.

  • I can see/control the “on/off” state.
  • E.g. Voltage, Current appears as field, but doesn’t have a value

I’m wondering if I need to do some kind of manual mapping to “help” HA better understand the capabilities of the socket? Or to force somehow the re-descovery of the socket? In zigbee2mqtt, initially, it was saying “interviewing failed”, but the device seemed to work, at least partially. I also observed that the current was in A instead of mA. After the last re-pairing attempt, the interviewing was OK, and the issue w/ A/mA was solved.
Maybe HA saw for the first time the socket when it was “corrupt”, and that’s why it works like this now?

Thanks a lot in advance.

I’m answering my own question.

1/ it seems that some parameters of the socket are disabled by default. I don’t understand why some are enabled and some not. This is how I enabled:

2/ I do think the “discovery” is a multi pass process. Sometimes, the on/off button is shown as 2 buttons. And after a while (I interpret that new JSON arrive and are reparsed), it switches to one button.