[SOLVED] Pioneer receiver stopped working in HA

I’ve had my pioneer receiver working for quite some time, however it seems to have now just stopped and I can’t work out why!
In the config file I have:

  - platform: onkyo
    name: Pioneer AV
      HDMI1: "XboxOne"
      HDMI2: "Xbox360"
      HDMI3: "Chromecast"
      HDMI4: "Playstation"

If I go to the IP address, it loads the Pioneer settings page.
In HA, it’s showing as unavailable. I’ve checked the log and it has these errors:

 Logger: homeassistant.components.onkyo.media_player
Source: components/onkyo/media_player.py:231
Integration: onkyo (documentation, issues)
First occurred: 19:28:10 (1 occurrences)
Last logged: 19:28:10
Unable to connect to receiver at

Any help greatly appreciated.

Unplug the Pioneer for a minute.
Had mine do the same and that reconnected it.
You may need to reboot HA afterwards


Thank you so much! Worked a treat :smiley:
Will remember that for future.

I have mine on a smart outlet and cycle power daily. I found it would sometimes work for a few days or a week, etc. So far with daily power reboots (off one minute, then back on) it has worked perfectly.
It seems the NIC they use gets upset with polling, and locks up after a while, never had issue prior to using with home assistant.

If you can hardwire, do that. No more issues.