Solved - Popp outdoor switch - "Switch: Turn off" command turns the switch on?!?

Hi everyone

Have been running a HA setup with both Z wave (16 devices) and Zigbee (37 devices) for a few years. Just recently one of my Popp Outdoor Switches started to act up. Currently I have 3 such switches, but only one has been acting strange.

If you click the icon to off or an automation runs the command “Switch: Turn off” it seems to do a double command which leaves the switch turned on instead of turned off. Tracing an automation shows that the following actions are done:

(switch.popp_smart_outdoor_plug_ip44_rated_3) turned off
(switch.popp_smart_outdoor_plug_ip44_rated_3) turned on

Trying the same automation for the other two switches results in only one action being run (ie the correct one).

Clicking the icon gives the following odd row in the logbook:
Popp1 turned on triggered by service Switch: Turn off

All 3 switches have the same (3.15 ie latest) firmware and HA is at the following levels:

  • Supervisor 2023.10.0
  • Operating System 10.5
  • Frontend 20231002.0 - latest
  • Z-Wave JS Driver 12.0.2 Server 1.32.1

Physically pressing the button on the device turns it on or off as it should.

I am currently at loss, does anyone have an idea what could cause this?

Does the device actually turn off?

It is possible that the On is not reflective of a command but rather a report coming in from the device.

You should be able to control the switch from within the zwavejsui (which takes HA out of the path).

Any errors in the log?

Does the zwave device configuration parameters look correct?

I’ve had 5 of these and 3 have died on me. When they died the “kind of” worked via z-wave, but were not responsive, and then after a while they completely stopped. I’d suggest replacing it.

There seems to be no errors regarding that device in the logs, and it reports its status correctly (ie if its on or off) both if you press the physical button or if you send a command through HA. But you can only turn it off by using the physical button on the device.

Have not tried zwavejsui,

Will try the latest update for Z-Wave JS and report back later

Thank you for the input, was hoping to not have to buy new hardware :slightly_frowning_face:

But good to know that there I shall not hunt a solution forever.

Problem has been solved. :grinning:

Going through logs and settings I went and checked the configuration of the device and saw that “Switching behavior” was set to ON (the fine print under that parameter said “Switching behavior when receiving wireless OFF”). Changing that parameter to OFF got it back to working as intended again.

Still a big mystery how that parameter got set to the wrong state (and only for one of my identical devices).

Thanks to all that gave input and hopefully this can solve someone else’s problem.