[SOLVED] Preparing Home Assistant for 2 hours

Tags: #<Tag:0x00007f3265624578> #<Tag:0x00007f32656243c0>

I installed the Supervisor in docker on an old laptop running Lubuntu 20.04.
I finally got to the point where I saw the initial page “Preparing Home Assistant” but it’s being doing it for more than 2 hours now.
Also, when I check my real-time network traffic, I can see that it periodically downloads and uploads something about every 20 seconds or so.

Please advise.

Stay patient.

Btw, did you know that you can click that pulsating blue disc beneath the “Preparing Home Assistant” label to get some more details?

1 Like

No, I didn’t know! Thanks.
I decided to restart my computer and now I can’t even log in to my desktop!
So something is messed up with my installation.
I will restart from scratch after reinstalling Lubuntu.

So I restarted from scratch and still getting the same problem. This time though, I clicked on the pulsating blue dot and now I can see where it is stuck:

21-01-14 05:30:10 INFO (SyncWorker_0) [supervisor.docker.interface] Downloading docker image homeassistant/qemux86-64-homeassistant with tag 2021.1.1.
21-01-14 05:30:48 ERROR (SyncWorker_0) [supervisor.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:2021.1.1 -> 404 Client Error for http+docker://localhost/v1.41/images/homeassistant/qemux86-64-homeassistant:2021.1.1/json: Not Found (“no such image: homeassistant/qemux86-64-homeassistant:2021.1.1: No such image: homeassistant/qemux86-64-homeassistant:2021.1.1”).
21-01-14 05:30:48 WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec

And it keeps doing this over and over.

Advice?

This error usually is due to a lack of storage space. The image file it’s looking for doesn’t exist because it lacked space to download and save the file.

1 Like

Thank you for the suggestion to click on the pulsating blue dot. Thanks to you, I was able to determine at what stage of the initial configuration it was stuck.
Without you, I would not have been able to fix the problem.

You were 100% correct!
I messed up when I installed Lubuntu on my laptop: I created a root partition that was too small.
I have marked your post as the solution.
Thanks a lot!

1 Like

I just received one of the Odroid Blue, but w/o the Blue case, I got it with the plastic ODROID case, which is fine. I’m currently receiving the above error with the Preinstalled image. Any suggestions on how to fix as I would assume the partitions have all been setup. I guess maybe I’ll have to attach it to a monitor to troubleshoot further?

I notice the 404 error is pointing to the localhost, is that correct?

That is correct.

So i have to guess then that the docker image wasn’t included on the Odroid i received, does that sound correct?

I also just received to odriod with HA preinstalled and it’s stuck on the preparing screen. When clicking the blue dot I see a lot of error messages. What should I do? Can I fix myself or do I need to send back?

See screenshot

This is what I did. Your mileage may vary…

I attached a keyboard and monitor to my Odroid. It booted up to a login. Login with username root, no password. From the resulting command prompt I ran the command

ha os update

My Odroid was connected to ethernet, performed an update, and upon reboot, was back to the blue dot, but things were happening and I’m back in business. A little struggle at the start, but pretty smooth after that. I’ve already turned off my old RPi4 w/SSD and have everything running on the Odroid.

Good luck, Jim

1 Like