[SOLVED] Restore intergration/platform DSMR after deletion

Hiya all,

I had some problems with DSMR platform. Also my reading device changed IP.
I mistakenly deleted the DSMR integration thinking I could add it again en configure it.
But I can’t find it anywhere to install again.
Probably because it’s internal integration and only has to be added in configuration.yaml.
My entry in configuration is valid but nothing happens. No errors, no entities…
Meterreaderdevice is working fine.

Anybody any idea how to get the integration back?

Thnx in advance,

DSMR does not yet have a UI config flow, so you need to add it to configuration.yaml as mentioned in the docs.

I did. And the integration was shown in intergrations tab,
But I removed it there,
Now, despite an entry in configuration.yaml, it won’t work anymore.
So it looks like the core integration is gone and I don’t know where to manually install it again,
Any thoughts on that?

Grtx, Richard

It should re-add the integration when it is in configuration.yaml. It only does that on restart of HA. Did you try to restart?

If it doesn’t come back, something went wrong with the connection validation.

I did re-enter en several restarts and reboots,
Also upgraded to latest versions.
Nothing happens and I see no logs about connection, The external module connected to the meter is working properly. I can access it via webbrowser on the correct ip, The Ip of homeassistant also is not changed,
This makes me suspect that the addon module of integration within HA is gone. But I don’t know where these are located therefore I can’t check.

It’s totaly weird,…
Hope you know the location but htnaks anyway for your efforts to respond.


Then probably connection validation fails.

Could you start by sharing your configuration? Also, could you try to add to the logger:

    dsmr_parser: debug

And check if you see something in the logs?

Sorry for the delay.
'The log only shows this2020-11-27 01:00:52 DEBUG (MainThread) [dsmr_parser.clients.protocol] connected
2020-11-27 01:01:22 INFO (MainThread) [dsmr_parser.clients.protocol] disconnected because of close/abort.

I don’t know exactly why and how but after some upgrades en reboots of both HA and meter reader it’s suddendly working again.

There was a sort of connection problem between meter reader and HA. After reconfiguring and reboot meter reader it worked.

Case closed.
Thanx to @RobBie1221 for taking the time to respond and advice.

@woestric did you use the intergation? Was it for a DSMR WIFI? I cant seem to get it connected throught the network. Did you?