Home Assistant Community

[SOLVED]Sonoff Basic R1 does not connect to Unifi APs

#1

Hey guys,
I seeked help both on the Ubiquiti forms and on reddit but unfortunately had no luck fixing this.

So im coming to our own community, in case someone had a similar issue and fixed it.
Here is my issue:

I recently bought two APs to replace my old tp-link set up.

I should say that i have a very basic networking knowledge, i had home routers/aps all my life fiddling with the basic settings but now i’m trying to set up a robust network at home and slowly dive into the details offered by my new hardware.

I am currently running a MIKROTIK RB951UI-2HND router, connected to my ISP’s modem, and have two Ubiquiti APs, an AP-LRv2 and an AP-AC-LR.

My IoT devices started crowding my network so my guess was to upgrade my network hardware before spending time to troubleshoot connection issues.

The experience has been discussed by other users online but i have a slight differentiation (regarding hardware versions) so Im coming here to ask in case we can find a solution that does not involve me getting up on the ceiling and replacing the devices i have hidden inside lamp fixtures.

  • After a lot of trial and error and troubleshooting last night, i have concluded to the following:
  1. Sonoff Basic R1 (Any eWeLink sw version) do not connect to any Unifi AP
  2. Sonoff B1 lamp on latest FW, does not connect to Unify AP
  3. Sonoff Basic R1 flashed with tasmota connects OK to Unifi AP (need to have old,tp-link AP off or it only sees tp-link when both are broadcasting but, that’s another issue)
  4. Sonoff Basic R2 connects OK to Unifi AP on any eWeLink sw version
  5. Sonoff 4ch Pro R2 connects OK to Unifi AP with no problem.
  • I have several devices of the aforementioned types, so that rules out being a single device issue

I cannot find any documentation about the diferences of R1 vs R2, besides the obvious HW upgrades, but here is the manufacturer’s product page

I tried stuff mentioned on the forums like:

  • Switching 5G radio off, then on, then off…
  • Applying different SSID on the 5g radio
  • BandSteering is off
  • Reset and re-paired a device on the same SSID (as someone suggested that the sonoffs would bind to the ssid’s MAC) with no luck
  • Turning on Legacy Mode.
    Settings > Wireless Networks > Edit WLAN Group > Legacy Support
    Still nothing
  • Auto-optimize network is off.
  • Tried WPA (instead of WPA2) just to troubleshoot, no connection.
  • Lowered 2G Data Rate Control to get full device compatibility, nothing (Settings > Wireless Networks > 802.11 RATE AND BEACON CONTROLS > 2G Data Rate Control > Enable minimum data rate control)
  • If i plug my old tp-link router back on, (while having the same SSIDs running on the Unifis) all the remaining devices connect.

Does this indicate that the R1s dont even see the unifi SSIDs broadcasting?

Doesn’t the fact that all the R2s connect on any software version indicate that it’s not a ewelink issue?

And doesn’t the fact that the R1s connect when flashed with tasmota indicate that it’s not a hardware issue?

I am very new and very lost to this issue.

I would greatly appreciate some guidance or tips from some more experienced user

Thanks in advanceMan Happy

1 Like
#2

IoT Wi-Fi devices only connect at 2.4G. There are only 3 non-overlapping channels there. 1, 6, & 11.
What channels do your old router settings use? How does that compare to the new ones? You could try forcing the new ones to use the same channels as the old ones. Unless I set them my current wireless routers insist on using the same 5G channel, interfering with each other. I am not using Unifi although I am considering it.

#3

I have tried with the 5g radio on different SSID and with the 5g radio off.
Devices connect to my old AP with any channel setting.
I have tried the 2.4g radio on my new unifi AP with 1-12 channels, no luck.

:cry:

#4

Could you not flash the remaining R1’s with tasmota, or even try esphome?

I have 2 AP-AC-LR and all my devices have no issues connecting, including tasmota when i used it and ESPhome that i migrated to.

it does seem like its a ewlink issue though. Plus as @Bosborne mentioned all those devices listed only support 2.4g

#5

Yes, i could, but they are already on the ceiling within the light fixture. I would like to avoid that.

Yes, i have a 2.4g radio on, they wont connect to it. (my 5g is off or on another ssid)

#6

Have you tried the ewlink app on another device, either android or ios?

#7

You mean unpair them and pair them again using another device?
I’m not very optimistic, but could try it (this also includes me climbing on the ceiling :stuck_out_tongue:)

#8

if your going up in ceiling, opportunity to upgrade to tasmota or ESPhome???

#9

hahaha, it just bugs me that i have to do that procedure just because i upgraded to a - very well recommended- AP.
There should be a workaround.
Plus i’ll lose my direct remote access through ewelink if i flash tasmota/esphome

#10

i wonder if the stock firmware binds to the original AP and only can be updated by a reset?

#11

https://support.itead.cc/support/discussions/topics/11000018230

#12

@aidbish that is not the case I have changed AP and all sonoff reconnected just fine so I don’t think binding is the issue. It is more likely the country code settings for both. Use of the 2.4ghz spectrum whilst mainly universal does differ from country to country for example we can use up to 13 channels here in Australia but if someone from the USA tried to use a laptop it wouldn’t connect any channel above 11. @krash could you post your ap 2.4g settings for me to have a look at?

#13

Tried that too:

On this:

I did connect to my old router (didnt need to do his AP trick) and updated one of my devices to the latest fw. It does not change to second generation… in contrary to his experience.

#14

I did try all channels 1, 4, 6, 12.
They connect on all channels on my old AP
They dont connect in any channel on my new AP.

Let me see… here are my current wifi settings: (pasting from the unifi controller, all irrelevant stuff, just in case)

OVERVIEW
MAC Address XXX
Model	UniFi AP-LR v2
Version	4.0.15.9872
Board Revision	31
WiFi Experience (2g)	
26%
IP Address	XX.XX.XX.XX
Uptime	5d 16h 9m 36s
Memory Usage	71%
Load Average	0.00 / 0.01 / 0.00
Users	7
Guests	0


RADIO (11N/B/G)
Channel	
6HT20
Transmit Power	17 dBm / 20 dBm (EIRP)
Tx Pkts/Bytes	15,176 / 9.14 MB
Rx Pkts/Bytes	7,691 / 1.03 MB
Tx Retry/Dropped	72.4% / 1.9%
Rx Retry/Dropped	0.0% / 0.0%
Ch. Util. (Busy/Rx/Tx)	17% / 13% / 3%

WLANS
Name	BSSID	ESSID	Channel
Showing 1-1 of 1 records.
ath0	XX:XX:XX:XX:XX	*SSID*   6

image
image

Those are the settings on my AP LR (only 2.4g) want me to paste the same stuff for the AP AC LR (which has dual radios and is somewhat closer to the devices)?
Here are for the AP AC LR with dual radios:
image
image
image
image
image
5g radio is on but with different SSID

#15

ok so wireless settings look fine what is your password authentication mode?

I dont use unifi but I found no issues by setting mine to wpa-psk-auto if you dont have auto then set it to wpa-psk.

#16

You should always use WPA2-PSK if that is an option
WPA was designed to be used before wireless equipment could handle the more secure AES encryption of WPA2. That old original Wi-Fi equipment has long since died & been replaced.

#17

@bosborne agreed we should always use wpa2-psk just trying to help narrow down what the root cause of his issue is so we can then deal with it.

#18

Tried WPA1, im guessing that’s the WPA right? Still wont connect

Will try WEP too later, and report back.

#19

WPA1 Only and AES are not a valid combination. WPA2 added AES. The WPA seciruty protocols were rushed to marked because WEP is so severely broken, it is the same as no security.

Just place a sign in your front yard saying “Hack Me” :frowning:

#20

Agreed, just need to try things out to troubleshoot why those 4 devices won’t connect.