[Solved] Sonoff ZBBridge flashing Tasmota, no WiFi

Hello,

I am a new Tasmota user (I have a few Shelly modules that I managed to flash OTA) and I wanted to add the Sonoff ZBBridge to control zigbee modules.
I followed the tutorial from here to flash Tasmota.
Everything seems to be good, and I receive the “Flashing successful! Power cycle the device” message, but when I disconnect the ZBBridge from the USB to TTL dongle and power it through micro USB, there is no tasmota_xxx WiFi network. The ZBBridge seems to have 2 leds (one for WiFi and one for Zigbee) and only the one for the Zigbee part is on when flashing or when powered through the micro usb (green light).
I also tried tasmota-pyflasher and got the following output :

Command: esptool.py --port COM3 --baud 115200 --after no_reset write_flash --flash_mode dout 0x00000 C:\Users\User\Downloads\tasmota-zbbridge.bin --erase-all

esptool.py v2.8
Serial port COM3
Connecting...
Detecting chip type... ESP8266
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: 84:cc:xx:xx:xx:xx
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 2MB
Erasing flash (this may take a while)...
Chip erase completed successfully in 2.8s
Compressed 603424 bytes to 426175...
Wrote 603424 bytes (426175 compressed) at 0x00000000 in 38.1 seconds (effective 126.8 kbit/s)...
Hash of data verified.

Leaving...
Staying in bootloader.

Firmware successfully flashed. Unplug/replug or reset device 
to switch back to normal boot mode.

Everything seems good apparently, but the problem still persists.

I tried to debug the boot with putty but nothing appeared on the console.

Is it possible that I broke something when I soldered the wires to the PCB (knowing that I have no experience in soldering)? Even if both flashing programs seem to tell that flashing was OK?
Any ideas on how to debug this?

Thank you

Try tasmotizer

Hello,

The problem was me being a noob in flashing devices (obviously as this was my second time, and the first time I broke the board) :slight_smile:
After disconnecting (by accident) the wire that was connecting the IO0 with the GND, the PCB booted in Tasmota and I was able to connect to the WiFi. After reading a little about this, it seems that connecting the IO0 and the GND together puts the PCB in flashing mode (which allowed me to send the firmware).
After flashing, my mistake was to only disconnect the wires from the USB to TTL adapter and not disconnecting the IO0 and the GND.
Hopefully someone as noob as me will come over this thread and it will help him.

1 Like