[solved] Starting Docker Container conflicts with Fritz.box device tracker

Tags: #<Tag:0x00007fc3de44a030> #<Tag:0x00007fc3de449f68>

I have a very complete HA running on a Raspberry Pi for a couple of years now, and after a reinstall having only 1 service to reinstall left (PiGallery2), I thought: why not try Docker for this. Docker is new for me, but it seems good to use, so I installed Docker according to the docs, started the PiGallery2 container, and suddenly all my tracked devices by the devicetracker on my Fritz.Box appeared as “away” at once.
Stopped the container, stopped Docker and they appear as “home” again.

When I start any Docker container, even like the example docker run -it alpine /bin/sh It results in HA logs like this:
Mar 12 07:11:38 pi hass[4173]: 2020-03-12 07:11:38 WARNING (MainThread) [homeassistant.components.device_tracker] Updating device list from legacy took longer than the scheduled scan interval 0:00:12
every 12 seconds or so, and after a few minutes all of my tracked devices appear “away”.

When I stop the container, all devices appear back “home” as normal.

Why is Docker conflicting with my device tracker? What config on Docker did I miss that could change this?

Any help appreciated!

**Edit: first I thougth Docker backend causes the conflict, but it appears to be any running container.

Seems to be solved by adding the real IP of the fritzbox into the configuration:


  - platform: fritz
## next line needed to avoid conflict with docker
    host: 192.168.1.1

Weird but it works.