[Solved] Stuck with first boot

Hi group,

I was following the installation steps in https://www.home-assistant.io/hassio/installation/. However, I was stuck at this stage:

I’m using Raspberry Pi 4 with a 32GB SD card. What I’ve done with the installation:

  1. download the recommended HassOS 32-bit image for RPi4 in the link.
  2. Flash the SD card with the image.
  3. Insert the SD card to RPi 4 and power on it with monitor, keyboard and mouse plugged in.
  4. Press an Enter when the screen stuck. Then it starts to ask “homeassistant login:”

I didn’t input any information about my wifi or etc, so I’m assuming it has not downloaded downloads the latest version of Home Assistant as mentioned in the installation instruction.
Also, from some online resources, the home assistant account creation seems to via web browser instead of the command line in the booting screen. I’ve tried to login with my forum account info and it showed “Login incorrect” (I don’t think it should be this account anyway because it cannot connect to the internet for account validation).

So could anyone provide any information that how I could solve the problem or whether I’m on the correct path to install HomeAssistant? Thanks!

1 Like

The first start take a while, but I guess you were patient before writing this message.
Normally (my last install of a testsystem is two days old) you do not work on the console. You just wait for it to boot and start and then go to your router, find your IP and log in via the webinterface.

Since you have seen the webinterface, it should be nearly allright. With a fresh install it usually asks for a username, meaning, it need a new username to create the first useraccount. The password you should enter is a new one for this user. Then usually some more necessary questions turn up.

Do you have an error message in the login? can you post a screenshot?

Hi Ceecee,

Thanks for the information. However, I actually have not reached the stage of finding IP through router, let along the webinterface stage.

I’m currently stuck at the booting stage. It will stay in the boot without actually go to start page / desktop. In booting stage, it only shows some usb-related notification after around 1m30s. The longest time I’ve waited it to start is about 15 min. For such cases, is there anything I could do for it?

Also, just for a quick question. I’m assuming hassOS has a desktop and the web interface is opened when the desktop starts and is opened through hassOS. Is this correct?

Thanks!

That is quite normal. Home Assistant runs headless, there simply is NO start page/desktop. You can stare at that screen for a lifetime, you will never see anything else.

Just lookup the IP of your HA instance, go to a desktop machine, open a browser and go to http://IP:8123 where IP is the IP of your HA instance.

1 Like

Hi Francis,

Thank you so much! It solves my confusion. And the web interface works fine at my laptop.
Thanks for helping!

Regards,
-Rui

Hi,

I too fall into the same trap. I did not realize I had to stay on my PC when Hassio was starting and updating. I thought this had to be done on the RPI …

It took longer than expected to start, but thanks to this post, I managed to get a solution :slight_smile:

Also, I had to plug the RPI4 on a RJ45 for ethernet because it was not connecting to WiFi ?

Mine showed white letters on a black screen scrolling up then it all went blank and I’m stuck there nothing is happening, I use a rpi 4 model b, 32 gb card, no connection to internet.