[SOLVED] Tasmota 6.6.0 dimmer problem - MQTT light component not working

I had to update my server and reinstall everything. Now I am facing a problem that a tasmota flashed Tuya dimmer is not integrated properly.

Previous state
I flashed the dimmer with Tasmota, configured it for automatic discovery by HA and setup MQTT.
Result: A light component was discovered in HA, which I could put in my dashboard and easily dim the light or switch it on/off using the light card.

Current state
I updated HA as well as Tasmota and reinstalled everything (docker based). Everything works like a charm except the dimmer light. Configuration of the Tasmota dimmer didnt change: MQTT, auto-discovery. The dimmer sends and receives via MQTT and I can control it with the topics without problems.
BUT in HA, a light component as well as a switch component and a sensor component appears. With the switch, I can turn on/off the light, with a light card I can adjust the brightness, but I can only turn the light on using the button in the middle, but not off and the state is not represented (brightness nor switch state)
I then configured a new light component manually:

  - platform: mqtt
    name: "Dimmer Schlafzimmer"
    command_topic: "licht_sz/cmnd/POWER1"
    state_topic: "licht_sz/tele/STATE"
    state_value_template: "{{ value_json.POWER1 }}"
    availability_topic: "licht_sz/tele/LWT"
    brightness_command_topic: "licht_sz/cmnd/DIMMER"
    brightness_state_topic: "licht_sz/tele/STATE"
    brightness_scale: 100
    on_command_type: "brightness"
    brightness_value_template: "{{ value_json.Dimmer }}"
    payload_on: "On"
    payload_off: "Off"
    payload_available: "Online"
    payload_not_available: "Offline"
    qos: 1
    retain: false

I can confirm that the command topics work (POWER and Dimmer) as well as the STATE is sent with a JSON payload. Using the “Dimmer” command, turns also on the light, thus on_command_type seems to be correct as well.

I think it has something to do with my configuration/setup. Any hint howto debug further is highly welcome.

For now the problem seems to be that the state is not properly pushed to HA as the state is not reflected properly in brightness and switch, AND the switch only allows to turn “on”, but always shows an icon in the “off”-state…

thanks for your help!!

for completeness:

State topic as from MQTT: “licht_sz/tele/STATE”
State message example:


HomeAssistant version (docker): 0.97.1

In the mean time I checked the state response using mqtt sensor:

  - platform: mqtt
    name: "Dimmer Schlafzimmer Power"
    state_topic: "licht_sz/tele/STATE"
    value_template: "{{ value_json.POWER1 }}"
    availability_topic: "licht_sz/tele/LWT"
    payload_available: "Online"
    payload_not_available: "Offline"
  - platform: mqtt
    name: "Dimmer Schlafzimmer Helligkeit"
    state_topic: "licht_sz/tele/STATE"
    value_template: "{{ value_json.Dimmer }}"
    availability_topic: "licht_sz/tele/LWT"
    payload_available: "Online"
    payload_not_available: "Offline"

And all is displayed/read fine. Is there a known issue with the mqtt light component? Any help for further debugging is welcome


reverting to Tasmota 6.5.0 solved the issue with the light component as well as the manual configuration.