[SOLVED] The interface layout fails on port different from 8123 under Safari


Recently I started tampering with exposing the HA to external world. Long story short the layout goes all wonky when connecting via haproxy - but then I actually started experimenting with Home Assistant on local network with SSL certs and having HA on port 443. When I revers the configuration to the standard 8123 without SSL everything works OK.

Yes, after changing the “http:” section, I do update the Setings → Network → Home Assistant URL → Local Network, which is followed by whole VM reboot.

To add, I’m using the “HA Core” inside of it’s own VM, static IP, the devices.
Side note:
Issue can be replicated on mac OS safari, ios safari seems OK. Chrome seems OK (and yes, replies of type “just use chrome” are predictable, so please don’t).

Edit 2:
The Chrome doesn’t work 100% OK. After a while scrolling seems to stop working. Resizing page shows unseen part of the page, but navigating anywhere in the gui - scrolling is still not functioning (except for pages that are not HASS related - like zigbee2mqtt, terminal etc).

I will include a screenshot of how the layout looks like when it goes all wonky. (to follow up with few more to show the worst case).

Further screenshot.

And here is a screenshot of how it looks after few seconds when in completely falls apart.

Bump - and a question to moderator: have I posted this in wrong forum / tag ?

So, I’ve found what seems to an issue:

It seems that the “reboot HA” from within HA does not really mean “full machine reboot”(and I don’t mean the quick reboot thingy in the menu) … I don’t know why, but there seems to be some JS or some part of the OS that was keeping it self to old IP / port / encryption over reboot. I found this out when I was doing update on my proxmox cluster and had to reboot the host - hence the VM was rebooted (a proper way) - then all the problems with “promises” inside of dev console just magically disappeared.

Moral of the story - on network changes just reboot your hardware (or VM).

Moderator: please close this as issue is resolved.