[SOLVED] TTS broken after 2022.5.0 update

The breaking changes indicated that TTS would be affected. The release note for that breaking change is: The TTS base_url option is deprecated. Please, configure internal/external URL instead.

I have had voicerss working without issue for over a year, until this update. Voicerss does not have/use the base_url parameter. The voicerss documentation is not updated, with any changes that may apply to 2022.5…0

Anyone have any idea how to get TTS working again? I also tried google_translate, could not get it to work either.


[Solution]. The interesting thing for me, was that I was not getting errors in the log. In NodeRed, i was getting an API error when I tried to call the service with the text that was to be spoken. After carefully reading the debug message, I saw the problem. I ended up having to add media_source: to configuration.yaml and restarting to load the media_source integration. After doing this, it works again.


I got the same problem.
How did you add media_source to configuration?
Can you show your yaml?

Best regards

@dexxger Just edit your configuration.yaml. And add the integration. Here is a snippet. I did not have to add any options under media_source: for it to work.