[Solved] Tuya v2 integration

Hi everyone.
I use the Tuya v2 integration, since it offers me more possibilities (power and consumption data, as well as the control of devices that are not on the same Wi-Fi as HA).
I have never had authentication problems, entering the usual data (user, pass, Access ID, Access Secret and 34 as country code).
I stayed in version 2021.9.7, because the following versions gave me problems precisely with this integration.
I thought that version 2021.11.1 had solved the problem and decided to upgrade. But when it didn’t work, it went back to version 2021.9.7.
Then, I get the error “1106 Invalid Authentication” all the time, so I can’t integrate Tuya v2.
I have tried all kinds of solutions: change the dots in the email, change the password, create a new project, …
Is there a problem with the Tuya servers that makes it impossible to integrate now? Do you know any solution?


  1. Do not use the Tuya v2 integration
  2. Use the new Tuya integration
  3. Change the password of the app (Smart Life or Tuya)
  4. Enter this new password in the integration (along with the rest of the usual data: user, Access ID, Access Secret and country code).

Running smoothly

Can’t seem to get this to work either, same issue after doing the normal steps of change password, create new project. 1106 Invalid Authentication.
I’m using the ‘Tuya’ integration found within Hassio under Devices & Services → Add Integration → “Tuya” - there’s no V2 listing so I assume this is the one you used with success?