[solved] Unable to delete Shelly device

I recently suffered a power outage, after power was back on everything came back to life except one shelly plug s.

It doesn’t show in the integrations list:

If I try to re-add it the shelly integration claims the device is already configured:

It has the same IP address as before, it is reachable, it just doesn’t show and therefore its entity is unavailable. Restarting and rebooting didn’t help.

I would like to delete this device and reconfigure it, but it seems there is no way to do. Any ideas?

I am running HAOS on an Odroid N2
Home Assistant 2023.2.3
Supervisor 2023.01.1
Operating System 9.5
Frontend 20230202.0 - latest

What is the Shelly device? Could go to Shelly web site and look at troubleshooting in documentation.

Lets check if it shows up in disabled devices. I had the very same issue and found that I can’t re-add the device because it was dosabled somehow… On Devices and integrations page clisk on inverted trianle icon and the select Show disabled integration. If this is the case you will see it on separate card with red border. From there you can reenable or delete and then add again…
Screenshot 2023-02-11 at 10.07.58

@mirekmal did that, unfortunately doesn’t show there as well.

@lordwizzard as stated in the post: shelly plug s. But nevertheless, shelly does not provide specific instructions for that situation. Guess their Facebook community is my next stop…

Okay, so it is kind of solved.
Since I didn’t see the device any longer I decided to add another Shelly plug, so I could replace the missing one. Setup went as always but what do you know? After the new device was added the missing one resurfaced… well. I’ll mark this post as solved.