[SOLVED] - Using a shelly Plus PM BLE gateway to connect a Gardena bluetooth valve

Hello there.

I’ve just received my Gardena watering valve, that when started up was instantely recognized by HA, and working.

I installed it in its location, outside, and the bluetooth connection was lost.

1 meter away from the gardena there is a Shelly Plus PM, gateway BLE activated, but HA doesn’t see the gardena at all.

➜  ~ bluetoothctl | grep F0:5E:CD:2D:BF:08
[CHG] Device F0:5E:CD:2D:BF:08 RSSI: 0xffffffa0 (-96)
hci0 F0:5E:CD:2D:BF:08 type LE Public connect failed (status 0x08, Timeout)
[DEL] Device F0:5E:CD:2D:BF:08 F0-5E-CD-2D-BF-08

➜  ~ bluetoothctl info F0:5E:CD:2D:BF:08
Device F0:5E:CD:2D:BF:08 (public)
        Alias: F0-5E-CD-2D-BF-08
        Paired: no
        Bonded: no
        Trusted: no
        Blocked: no
        Connected: no
        LegacyPairing: no
        UUID: Vendor specific           (98bd0001-0b0e-421a-84e5-ddbf75dc6de4)
        RSSI: 0xffffffa3 (-93)

How can I debug this ? how can I check if my shelly is doing it’s proxy job ?
One thing to add, there are several sensor with the gardena integration, but I also need to pass commands to open the valve, Is this possible with the shelly BLE proxy ?

I tried to activate the Bluetooth Scanner in HA

# Example configuration.yaml entry
  - platform: bluetooth_tracker

But the YAML validation is stuck so I did not reboot HA to try.

Thx a lot,
I’m kinda lost here.

sometimes it does connect !!

[NEW] Device F0:5E:CD:2D:BF:08 F0-5E-CD-2D-BF-08
[CHG] Device F0:5E:CD:2D:BF:08 RSSI: 0xffffffa2 (-94)
hci0 F0:5E:CD:2D:BF:08 type LE Public connect failed (status 0x03, Failed)
[DEL] Device F0:5E:CD:2D:BF:08 F0-5E-CD-2D-BF-08
hci0 F0:5E:CD:2D:BF:08 type LE Public connected eir_len 0
[NEW] Device F0:5E:CD:2D:BF:08 F0-5E-CD-2D-BF-08
hci0 F0:5E:CD:2D:BF:08 type LE Public disconnected with reason 1
[CHG] Device F0:5E:CD:2D:BF:08 Connected: no
[CHG] Device F0:5E:CD:2D:BF:08 RSSI: 0xffffffa1 (-95)
[CHG] Device F0:5E:CD:2D:BF:08 AdvertisingFlags:
[CHG] Device F0:5E:CD:2D:BF:08 RSSI: 0xffffff9c (-100)
[DEL] Device F0:5E:CD:2D:BF:08 F0-5E-CD-2D-BF-08

EDIT 2 :
I just tried the ble_monitor (HACS) and my gardena does not show up
maybe this device is not BLE ?

Also my shelly can see it

shelly_notification:209 Event from script:1: {"component":"script:1","id":1,"event":"ble.scan_result","data":[2,[["f0:5e:cd:2d:bf:08",-82,"AgEGEQbkbdx1v93lhBpCDgsBAL2Y",""]]],"ts":1715588372.58}

I found the solution

The shelly BLE proxy can’t work in this situation, as they don’t proxy actual Bluetooth connections, they only support advertisements.

see Gardena Bluetooth Irrigation Bluetooth connection is unreliable · Issue #103117 · home-assistant/core · GitHub

I used an Atom Lite M5 to act as proxy

hi, thanks for your pointer. just to be sure:
you are now succesfully using the Atom lite for the Gardena, or was that the one that failed…
Asking because I have tried to use an Atom Echo configured for Proxy, and even though that seemed to initially connect correctly (btw, just as the Shelly 1 PM), that Echo also was unreliable

Only proxy I can use seems to be the Olimex POE, which keeps me awake because of those horrific leds (no case yet)

An Atom would be much nicer in that regard :wink: