[SOLVED]: Which ESP board is this and how to flash?


I have a great problem with this board, because I’m not sure about waht type of bnorad I need to select in ESPhome in order to flash.

The board is:


Thanks a lot,

Its an ESP32 mini, try looking here https://esphome.io/components/esp32.html and in this list https://registry.platformio.org/platforms/platformio/espressif32/boards for one similar.
The pinout has to match with yours.

It look like a clone of Wemos Esp32 D1. Test with wemos_d1_mini32, I have one similar.

I have the following erro when flash (esp32 connected to my local computer, not the Interl NUC with home assistant:


Any help please?.

Thanks in advance,


Could be a driverproblem. Try restarting your PC or reinstall the driver.

I restarted Windows 10, and it continues with the same problem. It’s impossible to flash the esp…

I have some esp32 that the only way to flash them (the 1st time) was pressing the boot button.

when is necessary to press the boot button?, only 1 time at same time that press the esphome option to install?

keep the button pressed while plugging it into the usb (giving it power)

Finally worked with the folling configuration:

  board: wemos_d1_mini32
    type: arduino

But it worked with another same board, I think that the first one have a brick and I don’t know how is possible to solve a brick in an ESP board…

Thanks to all for the help.


You would be the first one on earth being able to brick a esp in software, congrats!

I tried everything but only found hardware solutions to brick esps (providing 5V to the 3.3Vin Pin works good!) :brick: