[solved] Widget state is not changed when setting anything on homematic entity


i have recently set up a new instance of homematic os on my proxmox server together with a raspberrymatic ccu on a Raspberry Pi 2 with a HM-MOD-RPI-PCB. So far i was successfully able to pair all my heating thermostats with the ccu and pass those to my homeassistant. I have also created some widgets for the thermostats on a dashboard.

Now, when i try to set anything on the dashboard using the widget, it does not change the widget state. Allthough i have noticed within the ccu web-frontend, that my “commands” are passed through and set on the thermostat accordingly.
Example: I click on the heat button (with the flame icon). The widget still indicates, that the thermostat is set to automatic. But in the ccu and on the thermostat, i can see, that the mode is changed to manual, which is correct.

I have integrated the homematic ccu via YAML, like it is described in the examples. Here is the yaml-snipped from my configuration.yaml

      resolvenames: xml
      port: 2001
      username: "ha-user"
      password: "redacted"
      port: 2001
      username: "ha-user"
      password: "redacted"

Here are some infos from the haos

haos: 9.5
homeassistant: 2023.6.3
supervisor: 2023.4.0

My CCU infos

NEO SERVER: 2.12.1
XML-API: 1.22

I had to reboot my hone assistant instance. Afterwards the widgets refreshed accordingly! Problem solved!