[SOLVED] Yet Another....Custom Element Doesn't Exist Issue

[SOLVED] After lots of trial and error (and pulling my hair out), my issue came from my Garbage Collection Card configuration. There were a number of resources from this card and integration that did not follow the usual format of resources. I went ahead an deleted all of those and now no longer receiving Custom Element Doesn’t Exist. Unfortunately, I have not been able to replicate in order to show screenshots. But hopefully this can help someone down the road (not sure if it’s specific to garbage collection card/integration) or an install error.

It seems that every card installed after I had installed the Garbage Collection Card refused to pull resources correctly event though path names were correct.

—————————original issue————————

Hello HA Community!

Loving my HA journey so far (about 6 months in) and have learned lots. This is the first time I’ve had to ask for help. And I know this is a question that comes up a lot - I have done my research on this topic but still experiencing the issue.

My Issue: every NEW card I have installed (both HACS and Manual), I am receiving the Custom Element Doesn’t Exist. Old cards are working just fine (including Button-Card, Stack-In-Card, Mushroom Cards, Layout-Card, Sidebar card etc.).

It is only cards that I have downloaded in the recent weeks (so something on my end has changed). I keep things pretty simple, and try to stay away from any manual config. Most recently the new Bubble-Card is what I have downloaded and is producing that error

**What I’ve Tried:** After researching, I’ve cleared cache, manual and HACS install, updated and checked resources, uninstall and reinstall of the cards, full restarts of HA, I tried looking at Dev Options on Chrome.

What Kind of Works: The one way to get it to show up is to click the three dots in top right (overflow button), search the specific resource, open the resource, click UPDATE (without changing resource info), the card will magically appear.

Great, right? No so fast :slight_smile: . The moment I reload the page it goes back to Custom Element Doesn’t Exist.

When I do click the UPDATE resource button, it only allows the card to show on the device I performed that process. All other phones, tablets etc will still show Custom Element Doesn’t Exist.

Any ideas? It seems to be something with my config, as Chrome, Fully Kiosk and Companion App is doing the same thing.I couldn’t find anything in the main logs. Is there another log I can check?

What I’m Running:

Home Assistant 2023.10.5
Supervisor 2023.10.1
Operating System 11.1
Frontend 20231005.0 - latest

Full Metal on an Optiplex

All help is greatly appreciated! This is my first post, if there is any additional info needed please don’t hesitate to ask.

May I ask how you resolved the issue - if you have at all.

How did you resolve it ? I have the same issue but only on one of my device (nexus 9)

I’m the same but across all devices, but only for specific cards, e.g. stack-in-card.
It doesn’t matter what I do, I just can’t get this to show up.