[solved]Zigbee - add device problem

Zigbee (ZHA)
I have an existing network:
coordinator = CC2531
and 2 x Lumi door sensors

there are no connection lines in ‘visualization’, just the entities

Trying to add a CC2531 flashed as router

  1. Click on add device, show logs … no output
  2. Doesn’t add new device.

So… question:
Is this correct process?
Click on add device
power up new CC2531 - the green light comes on
no lights come on the original coordinator - should they?

You forgot to mention wich solution you are using.
Zigbee2mqtt or ZHA ?

My failsafe routine will all different brands of zigbee stuff is:

  1. Click add device.
  2. Walk to coordinator with device in one hand, toothpick in other (for consistent results, get within about 6’ of it).
  3. Press and hold the device reset button for at least 5 seconds (it should long flash at you).
  4. Release reset button and keep standing next to the coordinator until the device flashes again (usually 3 quick flashes).
  5. Check to see if device got registered then quick think up a name for it.

oops … edited

done all that, the router does not behave like a normal device. I don’t have problems adding ‘normal’ devices

To (re-)pair: Power on, press and hold down the S2 button for 5 seconds.

ZHA I can’t tell as I’m not using it. But it happened quite the same with my old cc2531 and z2m.
The trick was :

  • Stop the ZigBee network
  • Unplug router for 1min
  • Plug it back
  • Start the network
  • Pair new devices works !

That was he solution with older coordinator firmware on the CC2531. Should not be needed on the latest firmware. But yes, if you don’t have the latest firmware, this should work.

Problem solved… firmware for router was not working
found this firmware - all works