[solved] Zigbee Device from _TZE200_h4cgnbzg (Hama) connected but without control

Hello :slight_smile:

I am HA Newcomer and just bought 3 HAMA Thermostat from the same vendor.
The first has the following Manufacturer Name: “_TZE200_yw7cahqs”
This one is full functioning.
Temperature sensor is readable and target temperature can be set via HA.

The 2nd and 3rd have the same manufacturer:
Those two are problematic.
They are connected. I can read the data from their sensors (temperature and batterie power).
And when I change the target temperature on the device itself, it is hetting updated in HA.
But I can not set the target temperature in HA.
Every time I do, it is getting resetted.

I can still send them back and hope to get the better models, but shouldnt it work regardless?
I have time till 14.7 to decide :smiley:
If they dont work by then, then Ill just send them back, so no loss on my site

I dont really know where to look in the logfiles.
I Would appreciate some help here as well.

If I did something wrong in posting here, pls tell mo, so I cann correct myself for the future. :slight_smile:

Completely forgot the Basics:

I use ZHA via SkyConnect (with Silicon Labs Multiprotocol) on HA supervised (on Proxmox)

What I already did:

  • reconfigure
  • device reconnect
  • device hard reset

Any suggestions, 2hat I could try to set a target temperature?

Both are mentioned here zha-device-handlers/zhaquirks/tuya/ts0601_trv_sas.py at 9e210ba946069eeb9e2ae4d41dba362f0a399925 · zigpy/zha-device-handlers · GitHub

So I made them work! :smiley:
Thank you very much for that subtle push! :slight_smile:

For those wondering how, heres the related issue on github:

and here the quirk as solution:

Could you please explain what you did?

I’ve followed the links and tried them for TZE200_6rdj8dzm, but doesn’t seem to work - am I doing something wrong?

Solved customizing this quirk for the ME167

Is there any chance that these TRVs will be supported by HA automatically in the near future? Is there a regular cycle when custom quirks get integrated “natively” in HA? Or do I absolutely and for ever need the custom quirk?
I’m asking because I could wait a few weeks, if I know that I can avoid extra work…

If they are submitted to github they should make it in. Not usually as quick as z2m though.

I spent 20 minutes to figure out if this (quirk submitted to github) is the case, but failed. :sweat_smile:
The quirk has to be integrated into ZigPy? I have no idea where to look at. I just don’t see any folder “custom quirks” with hundreds of device specific files or anything like that. I don’t have any experience with github…

Another question: If I use the quirk in my HA, can it stay this way for ever? Or do I need to do something, if a device gets native support in the future?

However, I needed the TRVs working, so I tried my luck with the quirks.
I guess that more people will stumble over this thread, so I’ll post here the solution that worked for me end of November 2023:
-I used the quirk file ts0601_trv_sas.py as linked in this post:

-I modified the file as suggested in the linked post
-I needed to delete an pair the TRVs to get them work

Bonus tips for quirk newbies (I’m one as well):
-all the work can be done just in the HA file editor
-for me the custom quirks path in configuration.yaml did not work with a leading “/”, so I left that away