[solved] Zigbee2MQTT - saving zigbee network

I have Zigbee2MQTT hassio addon installed on a Docker setup on a Pi. In the addon config, I’ve defined a directory in my home folder for “data_path”. Like this:

But when I go to that folder after pairing a couple of devices, it’s an empty folder. I don’t see any errors in the Z2M addon. Am I incorrect in thinking that the zigbee network stuff is stored in that folder? I’d like to back it up, but it seems to be empty.


I’m also kind of confused about the MQTT server designation. The Pi that this runs in has mosquitto installed (not using HA’s MQTT server), and the default

“server”: “mqtt://homeassistant”,

Seems to work and publish to this localhost mosquitto server just fine. What should be the configuration if I want a different LAN device to be MQTT server, let’s say<> without any need for passwords?

  "mqtt": {
    "base_topic": "zigbee2mqtt",
    "server": "",
    "user": "",
    "password": ""

Is there some “global” MQTT server that HA instances know about? Is there a “//homeassistant” MQTT server configuration? I’m just wondering what the weird //homeassistant MQTT server is all about.

not sure I follow. are you using hass.io or a different HA setup?
by default docker containers cannot access anything outside the container.
So you need to add a volume to your docker command that points /home/pi/docker/zigbee2mq to /app/data (which is where the config is saved on the docker container)
in your config file you would need to point to /app/data

for the 2nd part, I don’t know as I use MQTT with a username and password and never tried without.

1 Like

Thank you for the reminder. Yeah, hassio container is setup with a user data bind to my raspbian pi user folder, but you’re right, specifying </home/pi/docker/zigbee2mq> wouldn’t work, as it’s not bound. I don’t know where the addon is keeping the network data - maybe its inaccessible to me.

Thanks for the helpful reminder.

1 Like