[SOLVED] ZW130 WallMote Quad on OZW beta no front button messages, but "rear button" does send messages

For some reason nothing happens for this wallmote viewing OZWADMIN log, BUT if I remove and add this device to my second testing zw key (aeotec gen5, same as the main system), it DOES show the keypresses in the log!!!

Removed and added multiple times, same outcome, works on demo system, does not on production system.

I know the node is working, it refreshes all attributes with ozwadmin, and doubleclicking the rear button shows a stream of traffic in the ozwadmin log.

Please help!


Reading the product documentation says the messages go to the device’s lifeline which defaults to node 1

My controller is Node XX, not 1, never before has this been a problem, with OpenHab (the last HA software I was using) I could set the Lifeline to node XX or “controller” and it was fine.

I cannot see how to do this in HA Openzwave, either in the gui, or the separate ozw-admin program.

Any pointers please?

PS: my test system, the controller is at the default address - 1, so my guess is that is why the wallmote works okay with that system and not this system.

My assumption was correct, once the correct association was set, it worked as expected.

See for a work around posting a mqtt topic, but really OZW should have taken care of it automatically.