Some people say don't buy Shelly Motion, but views vary

Hello all,
I want to be sure that you’re aware NOT to buy the Shelly motion sensors.
I have 7 sensors all setup with Home Assistant an everything works except that the sensors are real crap. They all drop offline on random times. At that moment you have to reset the sensor and do the setup all over again. I’m not talking about resetting a sensor once a month but it’s daily that at least one is losing all connection with the wifi. Sometimes the sensors are even completely bricked.
If you do a search on the internet you will see that I’m not the only one with this problems.

So, be aware of this problem before you buy!!!



Have you assigned static IP addresses?

Have you tried the latest beta firmware?

OTA update link:


Thanks for heads up. Do you know anyone else who has this problem? The reviews seem positive. Perhaps your wi-fi is not very good?

1 Like

All Unifi network, never have problems with wifi.
Search further than the unboxing reviews because I was also happy the first day.

I just got a reply on the Shelly forum with a link to a new beta firmware. I installed it on 2 of my sensors for testing.

fingers crossed :wink:


Yes IP is fixed and I’m currently testing the beta

I probably should.

On the plus side this does seem like something that could be fixed in firmware.

On the minus side I don’t believe this marketing claim:

There is no way you can run an always connected wifi device for a year on a 6500mAh rechargable battery. That would mean the device runs on less than 1mA. Not possible. It must sleep/disconnect.

6.5Ah - 20% (or the battery catches fire next time you recharge) = 5.2Ah

5.2 / 8760 (hours in a year) = 590uA equivalent 24/7 current consumption.

= Bullshit.


I had exactly the same problem with some Shelly 1 units (also with Unifi, and the reports suggest there may be a correlation there), although my 1PM is fine.

I tried all the Shelly beta firmware, which made little difference, but flashing the 1s to ESPHome completely eliminated the issue, pointing the finger at the Shelly firmware not playing ball with the Unifi APs. Obviously, you can’t go down that route with the Motions.

I have no problem with my 5 Shelly1s.
The reason why I changed to Shelly Motion from my Fibaro Zwave motion sensors was the battery life.
If the problems remain I’m planning to convert a Shelly Motion and a Fibao Motion in 1 unit so I can use the battery of the Shelly in combination with the Fibaro Zwave to get a good working sensor. I just have to investigate some more that this is feasable.

Yes I know but I don’t mind to charge the unit even once a month…

I’ve got 3 Shelly 1s. I’ve never noticed any of them drop off the network.

My Shelly EM had connection issues for a while but that was fixed with a firmware update.

Great, but I still have an issue with that sort of false advertising.

You’d notice if you had the same problem I had — they dropped off and would not recover until power-cycled. Seemed to be linked to the physical switch input changing, yet with exactly the same wiring setup I now have no downtime at all on ESPHome firmware.

Anyway, bit off topic, sorry.

It is not an esp, but I know nothing about the chipset they do say it has.

This is the closest I’ve come to a teardown image:

Regardless of the chipset you cant operate wifi on less than 1mA unless you put the device to sleep (and thus it is not “always connected”).


They say in their advertising that it is a new silabs low power chip. No chip number so hard to find a data sheet.

According to this it’s a silicon labs cortex m3.

The literature says the low power is from ‘integrated software-controlled sleep modes’. Sounds like this is why they drop off and not with esphome.

Looks like rob the hook up did a review and wound up setting a rest sensor to poll the sensor.


Good find.

Mmm… My shelly plug s also have a similar issue. They won’t even turn off sometimes when pressing the physical button on the device.

Won’t that drain the battery really fast? From the linked text, it seems that The Hookup was working with the (wired) Shelly2 switch, not the Motion Sensor (I haven’t viewed the video, though, so there may be something I’ve missed)