Some Z-wave devices not detected after moving to NUC


I just moved from Raspberry Pi to NUC. Z-wave is giving me some headaches. After lots of restarts and heals, 10 out of 14 devices are now properly showing up in Hassio again. That leaves me with 4 troublemakers. Any tips on how I can get these to show up again?

The troublemakers are:
2x Neo Coolcam door/window sensor (battery powered)
1x Neo Coolcam PIR sensor (battery powered)
1x Neo Coolcam power plug (mains powered)

One of the door/window sensors is showing up as an Unknown Device for Zwave, also there is no binary sensor present for it. It seems to be half recognized or something. The other 3 devices are not showing up at all.

Any help is appreciated!


Did you just move zwave files or readded all devices into network?

Does device show up as dead or just not show at all?
If not at all, did you try adding again like it is new device? thank


I moved the whole config directory (except database) over from the Pi to the NUC. The devices I’m mentioning: 3 of them are not showing up at all, one of them is showing up as an Unknown Device.

I just excluded one of the mentioned devices from the Z-wave network (by clicking Remove Node then press the physical button on the device 3 times to exclude it). Then restart HA and added it again. It is indeed recognized again. Yay! But when renaming the entity_id to the name it had before, that’s impossible because the item ‘is already in the entity registry’.

Any ideas on that perhaps?


I recently performed the same hardware migration, although my platform of choice was significantly different (from Hassio on an RPi to Ubuntu VM running Home Assistant in a venv).

My Zwave network refused to function properly regardless of how many times I reset and rebuilt the network until I moved my Zwave stick to the yellow “charging” USB port on the front of my Gen5 NUC. It’s been well over a week and I’ve only seen my network performance improve since I moved the stick. Maybe try that?


Thanks, I switched ports. I’m hoping the zwave network will survive reboots better now. Yesterday a device disappeared after a HA restart again :frowning:


If you haven’t already done so, you might want to try this Z-wave Graphing addon. This helped me determine whether or not my network was hosed, improving, and/or running extremely well. The latency values really helped me see the improvement over time. The only downside is that if your network is running poorly, then the graph won’t show paths between the hub and endpoints.


Thanks. I installed it yesterday. It is nice indeed! Unfortunately after another reboot a device dropped off the radar again. I’m starting to think I will have to start from scratch.


I have had the same problem. The solution was to edit the zwcfg_xxx.xml and the .storage/core.device_registry files and remove any reference to the deleted items. Be sure to make a backup first!
Restart HA and you will be able to rename the devices to their original names.


Same here.
What happens if you delete all z-wave nodes from the 3 files?
Will it build up again?

By the way, I have the stick connected to one of the ports at the back of the nuc.
It’s the front port better?


In my experience, I’ve had the best success with the Yellow USB port on the front of my NUC.

I can’t speak to the deletion of the content in those files as I never had to go that route.