Somehow managed to break my LimitlessLED setup

I have been running hass for a while now on a C.H.I.P. Computer (it is similar to a raspberry pi). Somehow I am able to wreck my setup just about every other time I make changes to my config files. Almost the only reason I run hass is to control lighting. I have two rooms with LimitlessLED bulbs.

Several times after editing config files hass stops recognizing the bulbs. Usually if I reinstall from scratch hass will again recognize the bulbs and I can copy my config files back in and start from where I left off. While this is an annoying process that makes me doubt the reliability of hass, I have been willing to do it, until now…

I have now for the first time experienced failure immediately after reinstalling from scratch and importing my config files. Hass claims the config is valid after running the config check, but the log shows that it is not loading the limitlessled component. I have experienced this before after I make a change to the config files. The thing is I never change the lights.yaml file which connects to the lights! I usually change scenes or automations when it breaks. So why would hass stop recognizing the lights altogether?

2017-05-19 08:51:00 ERROR (MainThread) [homeassistant.components.light] Error while setting up platform limitlessled
Traceback (most recent call last):
File "/srv/homeassistant/lib/python3.4/site-packages/homeassistant/helpers/", line 155, in _async_setup_platform
entity_platform.schedule_add_entities, discovery_info
File "/usr/lib/python3.4/asyncio/", line 388, in __iter__
yield self  # This tells Task to wait for completion.
File "/usr/lib/python3.4/asyncio/", line 286, in _wakeup
value = future.result()
File "/usr/lib/python3.4/asyncio/", line 277, in result
raise self._exception
File "/usr/lib/python3.4/concurrent/futures/", line 54, in run
result = self.fn(*self.args, **self.kwargs)
File "/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/light/", line 110, in setup_platform
version=bridge_conf.get(CONF_VERSION, DEFAULT_VERSION))
File "/home/homeassistant/.homeassistant/deps/limitlessled/", line 78, in __init__
self._socket.connect((ip, port))