Someone Please Update Snips.AI Help Pages

Someone Please Update Snips.AI Help Pages specifically for the current Hass.io platform.
https://www.home-assistant.io/hassio/installation/

My specs:
Hass.io image, HassOS 2.12
Home Assistant 0.95.4
Pi 3B v1.2
Snips.Ai 5.2
USB headset via direct connection to Pi

This is a fresh install of HA and no home automation anything added yet. I simply wanted to try out HA and getting it to talk programmatically and have yet to accomplish anything.

I made a post about my issues with Snips, but no one has answered.

So let’s take a different angle: The help page linked from the add-on details page needs updating.
https://www.home-assistant.io/addons/snips/

First issue is from the section Add-On configuration on the page linked above, the configs shown do not work. The page has:

{
  "mqtt_bridge": {
    "active": true,
    "host": "172.17.0.1",
    "port": 1883,
    "user": "",
    "password": ""
  },
  "assistant": "assistant.zip",
  "language": "en",
  "custom_tts": false,
  "tts_platform": "amazon_polly"
}

Now to further muddle things, take a look at what the HA Snips.AI GUI is actually presenting:

{
  "assistant": "assistant.zip",
  "language": "en",
  "custom_tts": {
    "active": false,
    "platform": "amazon_polly"
  }
}

Reading the first config, I would guess custom_tts is false, and it is using tts_platform amazon_polly.
The second config, the one that is currently defaulting in the Snips UI, reads like the amazon_polly is part of the custom_tts which is not active. Two different results entirely.

On the web page in the HA add-on details for Snips.AI, I can change the existing values of the existing section, such as true/false or the tts_platform, but any other changes are discarded when the app is restarted.

While we are at this point, can someone give a little more info on the help page about the "tts_platform": "amazon_polly" entry? Why is the default choice amazon_polly? That is a paid service, so unless it is something built-in under the hood it’s not going to work for all users. I feel like there is some information that is assumed to be known that I’m missing. For example, is TTS built-in this add-on? Do we have to separately install something to achieve that? I did try following this page:


But still failed to get anything working. (The TTS Help page has some errors also)

Also, the top of the snips help page has:

The Snips add-on depends on the Mosquitto add on to bridge to Home Assistant, so make sure that is installed.

However, I have seen other posts and help pages mentioning mqtt is now built-in to home assistant. I’ve not had luck in any manner of various installation and configuration attempts, so I still don’t know what is needed to actually get this thing to work (talk).

And, there is a Discord link on that Snips.AI page that if you follow you are greeted by a 9 month old message that Discord is no longer being used… :expressionless:

I don’t use Snips co cant help with your issues but if you have an improvement to the Snips documents you can you can help by contributing to upkeep of the documentation.

Instructions on how do do this are here:

Thank you for the input. Actually, I had clicked that edit link but it indeed was for editing and the problem is I do not know the correct information. If I felt certain about something I would not hesitate to assist.
I did not have the link you gave on the how-to though, so thanks again for that. I’ve saved it.

This thread may help. Snips.ai Voice Assistant - from questions to ultimate guide

@tom_l
I followed the instructions on the page you linked and a made a trivial change to the documentation that just got merged. My first contribution :grin:
As I learn more about HA, I hope to be able to contribute more.
Thanks for the link.

1 Like