Sonoff 4CH Pro R2 - switch turned on without request


I have a Sonoff 4CH Pro R2 since some years now and since some months, one of their switch (always the same) turn on by it self, without any user request (physically or via wifi). I first used Tasmota on it and I switch to ESPHome to see if it make a difference, but I still have the same switch that strangely turn on itself.

Do you have any idea of what kind of problem I could have ?

Thanks !

The 433Mhz chip on the Sonoff 4CH Pro R2 works independent from the ESP. It could have picked up a stray transmission. Try the 433 clearing button.

I never used RF on this device, so I don’t know how to set/reset RF codes. After some search, I think I have to press the R3 button (R3 is my problematic relay) during 7 seconds. I tried and it seems to have done something: the relay turned ON, then after a few seconds the relay turned off and the blue LED flashed several times slowly. If I retry, it seem does nothing.

It’s the right method ?

Thanks ! I tried it and I will see if it fix my problem…

No problem since 10 days, many thanks !