Sonoff button controls router outlet it's connected to


I’m using z2m with Home Assistant and I have several devices in my network.
Recently, I successfully paired a new Sonoff button (model SNZB-01) that connected to a router (an Aqara outlet, model SP-EUC01).
I noticed that every time I press the Sonoff button it toggles the Aqara outlet on and off.

Is there any way I can prevent the Sonoff button from controlling the Aqara outlet?

Below is a screen grab from my z2m map, including the Sonoff Button, the Aqara outlet and the coordinator.

Sounds like you need to try and unbind the button.

Thanks for the suggestion, Adam.
This is what the Bind tab looks like:

Do you mean I just hit unbind on the line with the Coordinator?

Try unchecking the OnOff box.

Thanks, I tried.
It stays unchecked for a brief period and then it automatically checks back on without me even navigating away from the Bind tab :frowning:

Try unbinding it from the coordinator and if that doesn’t work remove it from the network and try repairing it

Unbinding didn’t work, repairing rendered the Sonoff Button useless… It only reports the lqi and nothing else:

I tried to force remove it and read it, to no avail. No issues in repairing, just nothing exposed anymore. Really odd…

Following up on this, I finally managed to repair it AND have it not bound to the Aqara outlet. Sharing the steps I followed with the community, should anyone run in to the same issues I did:

  1. Physically removed the outlet from mains - as in had it on my desk, unplugged.
  2. Force removed the Sonoff Button from z2m.
  3. Restarted z2m from Home Assistant Settings, Add-ons, z2m (oddly enough only this helped repairing the button and it properly reporting back all it’s available settings - in previous attempts I had restarted the entire Home Assistant server instead of only the z2m add-on)
  4. Back in z2m, hit permit join (Coordinator only)
  5. Reset the Sonoff Button by pressing the reset button for 5 seconds until the red led flashes.
  6. The Sonoff Button pairs successfully, interviews successfully and gets configured successfully (this step was missing from the logs when I was restarting the entire Home Assistant server instead of only restarting the z2m add-on) before repairing.
  7. Plugged the Aqara outlet back into mains.

This seems to do the trick. One weird thing that I noticed, was that although I had Permit Join (Coordinator) only enabled, the button got bound to another router on the network instead of directly to the Coordinator as I would’ve expected it.

I hope in time the button won’t get rerouted through the outlet again, since the outlet is physically closest to it.