Sonoff DW2 no longer shows battery status

Hi there.
For a long time, I’ve been using a custom card to show the battery state of my devices… after I updated the HA core (once again) … only my Sonoff DW2 does not show anymore the battery situation… it shows ON or OFF…

Despite being a binary sensor, it has the battery state, and before, I just had to add to the entity and the custom card understands and shows the battery state, not anymore,

Does anyone know how to solve this?


Does anyone with the same issue?

I’m currently rebuilding my system and I can’t look it up but if memory serves it’s sensor.sonoff_100… for the battery.

System back up and yes it is sensor.sonoff_100…_battery

I also tried there… removing the “binary” and adding “_battery” …still nothing :frowning:

Tried to add “_battery_level” , “battery_status”, and also without mention battery word… still the same…

when it was working long ago… It was “sensor.sonoff_10011a340a” only…

For some reason DW2 has a switch entity, RSSI entity, and VOLTAGE entity…but not a BATTERY LEVEL entity… who cares about RSSI? i wanna if I need new batteries instead.

I just added mine 2 days ago. My Firmware is 1000.2.1122. It shows Battery and RSSI. It also shows up as DW2-Wi-Fi-L. I wonder if the devices firmware is the problem?

u mean u r not able to see the battery level either or u r talking about mine?

U sure the battery you see isnt the Voltage instead of level? can u send a print please?

It sucks because the app shows the battery level, so its not a big deal to capture the information, and ald mine has the latest firmware available… :frowning:

I am seeing battery level (100%) not seeing voltage.

Did you try deleting the integration for this device and then add it back in?

Yes, I did… yours is DW2-WIFI-L …mine doesn’t have this “L” … that´s why the firmware is different.

I will keep searching for a solution!

Thank you very much for you attention

I think I found an answer for you, take a look at this thread.