Sonoff GK-200MP2-B integration not working on Home-assistant in containers

I’m looking for a advice on how to troubleshoot the Sonoff GK-200MP2-B integration with home-assistant.
I have setup the camera with the eWeLink app. This works fine.
Getting it working in Home-assistant, however, is another story

I added the following to my configuration.yml file and restarted home-assistant


  - platform: ffmpeg
    name: westcam1
    input: rtsp://rtsp:[email protected]:554/av_stream/ch0

In home-assistant I can see the entity ID, but when I add a picture-entity card, I get no image
Here is where I’m getting on thin ice and I’m looking for help:
I suspect I am missing ffmpeg on my setup.
My Home-assistant runs in containers on a raspberry pi4 (with an external harddisk)

[email protected]:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"
[email protected]:~ $ docker ps
CONTAINER ID        IMAGE                                               COMMAND                  CREATED             STATUS              PORTS                    NAMES
ec0d0a99c256        esphome/esphome-hassio-armv7:1.16.2                 "/init"                  25 minutes ago      Up 25 minutes                                addon_a0d7b954_esphome
e4e57caf9fc6        hassioaddons/node-red-armv7:7.2.11                  "/init"                  26 minutes ago      Up 25 minutes                                addon_a0d7b954_nodered
baca32e63e23        homeassistant/armv7-addon-configurator:5.0.0        "/init"                  26 minutes ago      Up 26 minutes                                addon_core_configurator
753de5a1db90           "/init"                  27 minutes ago      Up 27 minutes                                addon_a0d7b954_grafana
6cc1e13eb486          "/init"                  27 minutes ago      Up 27 minutes>8086/tcp   addon_a0d7b954_influxdb
82777366f494        homeassistant/armv7-addon-samba:9.3.1               "/init"                  28 minutes ago      Up 27 minutes                                addon_core_samba
d9d42edc1bd9        hassioaddons/glances-armv7:0.9.1                    "/init"                  28 minutes ago      Up 28 minutes                                addon_a0d7b954_glances
e30684db1ceb        homeassistant/armv7-addon-mariadb:2.3.0             "/init"                  28 minutes ago      Up 28 minutes                                addon_core_mariadb
4b223c3466a7        homeassistant/armv7-hassio-multicast:2021.04.0      "/init"                  28 minutes ago      Up 28 minutes                                hassio_multicast
9b3cf184a887        homeassistant/armv7-hassio-cli:2021.05.1            "/init /bin/bash -c …"   28 minutes ago      Up 28 minutes                                hassio_cli
4eff73b521cb        homeassistant/armv7-hassio-audio:2021.04.0          "/init"                  28 minutes ago      Up 28 minutes                                hassio_audio
6a265051ae18        homeassistant/armv7-hassio-dns:2021.04.0            "/init"                  28 minutes ago      Up 28 minutes                                hassio_dns
ab89b4275ef1        homeassistant/armv7-hassio-supervisor               "/init"                  2 days ago          Up 29 minutes                                hassio_supervisor
b0be901462b0        homeassistant/armv7-hassio-observer:2020.10.1       "/init"                  2 weeks ago         Up 29 minutes>80/tcp     hassio_observer
f1cffe3639cb        homeassistant/raspberrypi4-homeassistant:2021.2.3   "/init"                  3 months ago        Up 27 minutes                                homeassistant
[email protected]:~ $ 

I tried to understand the documentation at: FFmpeg - Home Assistant and I installed ffmpeg on the Raspberry pi. (should it not be added to one of the containers instead?) but that did not help

[email protected]:~ $ sudo apt list --installed | grep -i ffmpeg

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

ffmpeg/testing,now 7:4.1.6-1~deb10u1+rpt1 armhf [installed]
[email protected]:~ $ 

Any tips on how to troubleshoot this are greatly appreciated

Solved: The issue was that the camera had gotten a different IP. (I need to figure out how to give it a static IP)
Also: the RTSP via the picture entity card has a huge delay
So, I added HACS and added this integration:
This works much better