Sonoff GK-200MP2-B IP Camera to wifi?

Tags: #<Tag:0x00007f73b01651e0>

Hi everybody,

who here has the Sonoff GK-200MP2-B IP Camera and was able to successfully connect it to their wifi?

I use pfSense as router and multiple UniFi access points, controlled by a unifi switch, and the controller software on my home server. I tried connecting it to my network countless times, and was going to give it another shot today. Still nothing. I get please use mobile phone for wifi configuration. Then I start the ewelink app and use sound pairing. Nothing else will work (or even try to connect to the camera).

After playing that awful noise for a few seconds, the camera will confirm wifi recognized data set. Then it will do it’s thing for a while. Eventually, I’ll get network error, please configure again. It might be password error, not network error, the sound quality is awful. Then I’ll get please use mobile phone for wifi configuration again.

I had previously connected the camera via ethernet, and it worked. I can access it, I can set an rtsp password, view the stream, etc. etc.

the camera supposedly only supports 2.4GHz. So I tried the following

  • have it join wireless network a (2.4GHz only network for some IOT devices)
  • create a new wireless network x with 2.4GHz only and maximum backwards compatibility via UniFi Controller and have it join that
  • remove the password from either of those networks and try connecting it this way

When any device joins my network, I can see this in pfSense, as it is my DHCP server. Any new device will be assigned an IP address, and cannot interact with my network until I change some settings. According to pfSense, the camera has never connected to the network - not even when there was no password to it! Also, I can filter connected clients in Unifi by uptime; if the camera had joined the network at all, it would show (even before receiving an IP address by pfSense; it would still show up there with no IP).

What options do I have? I know that the networks

  • exist
  • can be accessed from where the camera is (as I am next to it with my phone, and connected to them, when setting up the camera)
  • the password is correct => won’t connect even without password, and also, all my PWs are in a database; I even deleted the network from my phone and re-connected, being prompted to enter a password, and entered it in order to assure that the password I have in my database was still correct. It was, and the phone connected

I thought perhaps my phone had some bug with audio pairing, so I tested with another. Both my current Samsung Galaxy S9+ with a custom firmware, and my old Samsung Galaxy S8 with stock firmware produce the same result: camera supposedly trying to connect, throwing an error, starting from step 1.

Unfortunately, there does not seem to be a way to connect the phone to the wifi once it has been connected via ethernet. Otherwise I would try that. But when I connect the camera via ethernet cable and go through the settings, there is no WiFi setup. My issue with this is that I want to camera somewhere where there is no ethernet. Otherwise I wouldn’t have bought camera with wireless capabilities.

Has anybody here encountered this and can help me fix it? I contacted iTead (the Sonoff company) via email. They replied after a couple of weeks, asking me to provide a ton of logs that I couldn’t produce, so that went nowhere. I actually asked them for an ssh or telnet password, as the camera does expose on of those ports (don’t remember which one, and cannot test as it is not connected to my network atm). Of course they didn’t disclose this. It was a longshot, I just hoped that I could somehow get this camera working.

Thank you for any help fixing this :slight_smile: