Sonoff L2 LED Strip "Device is not supported currently" error in EWELINK Integration

Hi,

I’m currently having an issue with the Sonoff L2 LED Strips not showing up in Home Assistant via the EWELink integration. Currently it is grayed out with the error: “Device is not supported currently”

All my other devices are functioning perfectly

can anyone help?

Thanks

1 Like

Having the same issue with an eWe link gateway. Any luck figuring this out?

1 Like

Hi there,

I have a ewelink/sonoff wifi switch which worked, but it was not used for a while. Then I plugged in and showed the same as yours, ‘Device is not supported currently’.

Then I sign in ewelink app first to make sure switch works with app, then sign off and login again under ‘ewelink smart home’ add on, then it worked.

Hope that helps.

The issue has not yet resolved itself unfortunately. I get the same message for my ZBBridge, however my devices connected via the bridge seem to work without any issues

Hi,

I am having the same issue with gateway and L2.
Is that just because the controls are missing or is something actually broken?

**Edit: The led strip does work from the ewe app

Yeah mine also works from the Ewe app, just seems like it’s unsupported in home assistant.

@jarrydw So I managed to get it working using SonoffLAN, installed via HACS.
Not sure if there is a direct way of installing without using HACS.
Will be something I look into at a later date.