Sonoff LAN

Hi, I’m facing problem with 2 of my many Sonoff device which not able to pull into HA. It was previously running fine on HA version 2024.3 but once upgrade to 2024.4.3, this 2 device went offline. I tried delete from Ewelink apps and add back again but still not able to get it into HA. Error logs as below

Logger: custom_components.sonoff.core.ewelink
Source: custom_components/sonoff/core/ewelink/
integration: Sonoff (documentation, issues)
First occurred: 17 April 2024 at 15:13:25 (6 occurrences)
Last logged: 17 April 2024 at 19:49:57

  • 1001fe638c !! can’t setup device
  • 1001dfded1 !! can’t setup device

Traceback (most recent call last): File “/config/custom_components/sonoff/core/ewelink/”, line 60, in setup_devices entities += [cls(self, device) for cls in get_spec(device)] ^^^^^^^^^^^^^^^^^ File “/config/custom_components/sonoff/”, line 94, in init self.report_mint, self.report_maxt, self.report_delta = reporting ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ ValueError: not enough values to unpack (expected 3, got 2)

Anyone can help?

What is the model of the devices? Have you logout of eWeLink app and back in? Have you then restarted HA after?

Is not from Sonoff but generic OEM brand. 1 is a power plug and the other is a wall switch for aircon. Both with power monitoring function. I have other similar device but the rest are ok. I tried logout and back in, delete and pair again, pair with anothe ewelink account. All failed. Yes, I had restarted HA after everytime.

SonoffLAN just put out a new version 3.7, which added new country support and new devices. Try updating it.

Thanks, how do you check which version are you currently running? There isn’t any prompt for updating the Sonoff intergration.

Goto: HACS → Integrations → Sonoff LAN → Three vertical dots on the upper right → Upgrade Information.

Fyi: I did update Sonoff LAN to 3.7.0 yesterday (v.3.7.1 just got released) and some of my devices went offline after the update. The remedy was to reboot the HA host (not just restarting HA) and all went back to good again.

Thanks. I updated to 3.7.1. Even worst. Now my RF devices goes offline. I rebooted my host. Still the same

Then you are having network issues (look at your router) with mDNS (multicast) which is needed to communicate with the devices. Are all devices on the same IP address range (also known as subnet)? All IoT devices placed in the same vLAN?

So are these the PowStro knockoffs of Sonoff sold on eBay?

Yes, they are in the same IP segment. Don’t think it is network issue as I can control them in ewelink apps

I got it from Shopee. Not sure ebay or not.

Hi. Had same problem…Installed 3.7.1 and integration failed with most of sensors but there is a new version 3.7.2…I installed, reboot and integration is running again…

Thanks, will give it s try.

Ok. Problem solved. Thanks to Alexxit. He pointed out that there is an error on my config file. There are only 2 elements whereby should have 3. Funny thing is I did not add this in my config. It was added automatically.

power: [30, 10] # update interval (seconds), history size (days)
power: [30, 10] # update interval (seconds), history size (days)