Sonoff NSPanel Pro fw V2.2.0 / ZigBee Router Feature added

Hello guys,

Since I’m looking for a new thermostat, I’m very interested about the NSPanel Pro.
I saw that recently Sonoff added a very cool feature:

New Updates:

  1. Support switching NSPanel Pro from Zigbee gateway mode to Zigbee router mode. Click ‘Device Settings–Pilot Features–Zigbee Mode’ in the APP to enable Zigbee router mode. After switching to a Zigbee router, you need to bind it with other gateways.

This is a Game changer for me, since I have a 3 floors house with minimum 3 thermostats point.

Do someone know if it’s possibile to use this Firmware with adb in use and HA Companion installed?

Thank you in advance :slight_smile:

1 Like

It works, all good. I have mine paired up with Zigbee2Mqtt. Just make sure to setup the panel using the eWeLink app first.
Switch the ZigBee radio over to router mode, and then set the panel into developer mode and install the home assistant companion app using ADB :slight_smile:

Helpful links:

2 Likes

First of all, thank you!

I was totally sure about that was necessary to downgrade the firmware.

So, if I receive the device with an older firmware, I just need to activate it with the app, upgrade it to the latest fw, and then follow the procedure suggested?

Exactly yes, you don’t have to downgrade the firmware to make this work.
Mine arrived with 1.7.0, I updated it. And then enabled dev mode and installed the companion app.

Has anyone worked out how to enable the Zigbee router mode on an NSPanel Pro where adb has previously been enabled? I’ve updated the firmware to >= 2.2.0 using GitHub - seaky/nspanel_pro_roottool_apk but haven’t worked out the next step.

Sure, u need to go in the eWeLink app, Settings, Experimental Features, ZigBee Mode.

Tap on “Router Mode”. it will erase your data if I remember.

Last note: after the device reboot I went to “link device” in order put it in pairing mode, but it failed. A reboot fixed this error.

1 Like

I don’t have access to the device in the app anymore once Developer Mode / adb is enabled. It just shows as offline and the section where I can enable zigbee doesn’t show up (I have another one I got later where I enabled zigbee before enabling developer mode). I might try a factory reset on one of them and see if I can get it to show up in the app.

Are you sure the Sonoff App is opened on the device (NSPanel)? If you close that app, eWeLink won’t detect it.

1 Like

Thanks, that made it show up in the app again, but unfortunately that NSPanel Pro doesn’t have the “Pilot Features” in the settings.

Did you end up finding a solution? I have the same issue of no pilot features menu item.

What if I didn’t do that!?!? Anyway to change it afterwards???