Sonoff RF Bridge Corruption / Crashing Issues

Morning all,
I’ve got two sonoff RF bridges (one was purchased yesterday as i thought there was a hardware issue)

After a period of time, could be hours could be minutes the tasmota interface starts to look strange, and it stops passing information to HA. After taking a look on the web pages it looks like there is an issue. I’m not convinced that this is a hardware issue as it is happening on the replacement that arrived yesterday. the RF bridge was working ok for a couple of months but started playing up a couple of days ago. Any ideas what could be going on? The pages look like this:

Both were setup as module 25 (Sonoff Bridge)
This is really frustraiting as i’m just in the middle of setting up PIR sensors for security and automation.

That does look weird and I don’t have an answer but in case you don’t have any Sonoff 4ch, (so you wouldn’t know), it looks like you have a cross between them and the RF Bridge.

I only offer this as extra information that might help you. Often I have solved problems after finding out something apparently unrelated.

Good luck.

I do have a 4ch pro (but it’s not setup yet.)
If i unplug the RF bridges and leave them for a while, then reconnect they work as expected. I’m getting really annoyed with it as some of my automations rely on them detecting the doors being opened.
As the 4ch pro has an RF chip can that be used to pick up on the RF devices in the house and pass them back like the rf bridge?

Sorry my 4ch aren’t the Pro ones so they don’t use RF but I thought the RF in the 4ch Pro was merely a receiver to operate the relays…

Have you tried re-flashing the Bridge? It does sound VERY strange.
Is it definitely retaining it’s module type (25) when it goes weird?
Also which version of Tasmota re you using? I’m no expert but it sounds like something is up with your firmware.

Thanks Klogg.
it is retaining the module type, but just starts acting strange (webUI issues, not logging RF signals in the console etc.)

I flashed all of my devices with 6.2.1 then done a 6.3.0 OTA update on all of them. I’ve also tried to re-flash both of the RF bridges with 6.2.1 and 6.3.0 directly using FTDI adaptor, and I get the same results.

I’m not having the issue with any other hardware (A number of sonoff basic’s, 6* S20’s and 3* H801’s)

Could it be some strange interference on the 433 channel?

Been watching the console and saw this… the bridge has also just dropped off the wifi.

12:45:13 MQT: tele/RF_Bridge/STATE = {"Time":"2018-12-09T12:45:13","Uptime":"0T00:30:16","Vcc":3.190,"Wifi":{"AP":1,"SSId":"Wan17","BSSId":"FC:EC:DA:AA:1C:24","Channel":6,"RSSI":100}}
12:50:13 MQT: tele/RF_Bridge/STATE = {"Time":"2018-12-09T12:50:13","Uptime":"0T00:35:16","Vcc":3.182,"Wifi":{"AP":1,"SSId":"Wan17","BSSId":"FC:EC:DA:AA:1C:24","Channel":6,"RSSI":100}}
12:55:13 MQT: tele/RF_Bridge/STATE = {"Time":"2018-12-09T12:55:13","Uptime":"0T00:40:16","Vcc":3.190,"Wifi":{"AP":1,"SSId":"Wan17","BSSId":"FC:EC:DA:AA:1C:24","Channel":6,"RSSI":100}}
13:00:13 MQT: tele/`��FU��0�
13:02:00 MQT: tele/`��FU��0�
13:02:26 MQT: stat/`��FU��0�
13:02:26 MQT: stat/`��FU��0�
13:02:26 MQT: stat/`��FU��0�
13:02:26 MQT: stat/`��FU��0�
13:03:51 MQT: stat/`��FU��0�
13:03:51 MQT: stat/`��FU��0�
13:03:52 CFG: Use defaults

Very strange and at the moment I can’t think of anything to add. One of the experts on Sonoffs here is @digiblur. (Hopefully he won’t mind me tagging him :sunglasses:)

So Just to add to the strange issue. After it went offline, at somepoint it restarted with the original configuration, broadcasting an SSID of Sonoff-xxxx and lost all of it’s settings.

This bridge us driving me mad. I’ve been sittin here looking at the logs, and it’s not gone “funny” but i am noticing the following, the signal is good, and not other devices are repoting issues connection to the broker.

21:49:46 MQT: Connect failed to, rc -2. Retry in 10 sec
21:49:48 DNS: Initialized
21:49:58 MQT: Attempting connection...
21:49:58 MQT: Connected
21:49:58 MQT: tele/RF_Bridge/LWT = Online (retained)
21:49:58 MQT: cmnd/RF_Bridge/POWER = 
21:50:12 MQT: Attempting connection...
21:50:12 MQT: Connect failed to, rc -2. Retry in 10 sec
21:50:15 DNS: Initialized
21:50:25 MQT: Attempting connection...
21:50:25 MQT: Connected
21:50:25 MQT: tele/RF_Bridge/LWT = Online (retained)
21:50:25 MQT: cmnd/RF_Bridge/POWER = 
21:50:33 MQT: Attempting connection...
21:50:33 MQT: Connect failed to, rc -2. Retry in 10 sec
21:50:36 DNS: Initialized
21:50:46 MQT: Attempting connection...
21:50:46 MQT: Connected
21:50:46 MQT: tele/RF_Bridge/LWT = Online (retained)
21:50:46 MQT: cmnd/RF_Bridge/POWER = 
21:50:51 MQT: Attempting connection...
21:50:51 MQT: Connect failed to, rc -2. Retry in 10 sec
21:50:52 WIF: Connecting to AP1 Wan17 in mode 11N as RF_Bridge...
21:51:00 WIF: Connected
21:51:00 DNS: Initialized
21:51:09 DNS: Initialized
21:51:12 MQT: Attempting connection...
21:51:12 MQT: Connected
21:51:12 MQT: tele/RF_Bridge/LWT = Online (retained)
21:51:12 MQT: cmnd/RF_Bridge/POWER = 
21:51:21 MQT: Attempting connection...
21:51:21 MQT: Connect failed to, rc -2. Retry in 10 sec
21:51:24 DNS: Initialized
21:51:34 MQT: Attempting connection...
21:51:34 MQT: Connected
21:51:34 MQT: tele/RF_Bridge/LWT = Online (retained)
21:51:34 MQT: cmnd/RF_Bridge/POWER = 
21:51:59 MQT: Attempting connection...
21:51:59 MQT: Connect failed to, rc -2. Retry in 10 sec
21:52:00 WIF: Connecting to AP1 Wan17 in mode 11N as RF_Bridge...
21:52:03 WIF: Connected
21:52:03 DNS: Initialized
21:52:13 MQT: Attempting connection...
21:52:13 MQT: Connected
21:52:13 MQT: tele/RF_Bridge/LWT = Online (retained)
21:52:13 MQT: cmnd/RF_Bridge/POWER = 
21:52:16 MQT: tele/RF_Bridge/STATE = {"Time":"2018-12-09T21:52:16","Uptime":"0T00:40:19","Vcc":3.218,"Wifi":{"AP":1,"SSId":"Wan17","RSSI":78,"APMac":"78:8A:20:2A:7E:8C"}}
21:53:21 MQT: Attempting connection...
21:53:21 MQT: Connect failed to, rc -2. Retry in 10 sec
21:53:23 WIF: Connecting to AP1 Wan17 in mode 11N as RF_Bridge...
21:53:27 WIF: Connected
21:53:27 DNS: Initialized
21:53:39 DNS: Initialized
21:53:40 MQT: Attempting connection...
21:53:40 MQT: Connected
21:53:40 MQT: tele/RF_Bridge/LWT = Online (retained)
21:53:40 MQT: cmnd/RF_Bridge/POWER = 
21:53:45 MQT: Attempting connection...
21:53:45 MQT: Connect failed to, rc -2. Retry in 10 sec
21:53:47 WIF: Connecting to AP1 Wan17 in mode 11N as RF_Bridge...
21:53:51 WIF: Connected
21:53:51 DNS: Initialized
21:54:01 MQT: Attempting connection...
21:54:01 MQT: Connected
21:54:01 MQT: tele/RF_Bridge/LWT = Online (retained)
21:54:01 MQT: cmnd/RF_Bridge/POWER = 
21:54:08 MQT: Attempting connection...
21:54:08 MQT: Connect failed to, rc -2. Retry in 10 sec
21:54:11 WIF: Connecting to AP1 Wan17 in mode 11N as RF_Bridge...
21:54:15 WIF: Connected
21:54:15 DNS: Initialized
21:54:24 DNS: Initialized
21:54:26 MQT: Attempting connection...
21:54:26 MQT: Connected
21:54:26 MQT: tele/RF_Bridge/LWT = Online (retained)
21:54:26 MQT: cmnd/RF_Bridge/POWER = 
21:54:41 MQT: Attempting connection...
21:54:41 MQT: Connect failed to, rc -2. Retry in 10 sec
21:54:45 DNS: Initialized
21:54:55 MQT: Attempting connection...
21:54:55 MQT: Connected
21:54:55 MQT: tele/RF_Bridge/LWT = Online (retained)
21:54:55 MQT: cmnd/RF_Bridge/POWER = 
21:55:00 MQT: Attempting connection...
21:55:00 MQT: Connect failed to, rc -2. Retry in 10 sec
21:55:03 DNS: Initialized
21:55:13 MQT: Attempting connection...
21:55:13 MQT: Connected
21:55:13 MQT: tele/RF_Bridge/LWT = Online (retained)
21:55:13 MQT: cmnd/RF_Bridge/POWER = 

This has come from a sonoff behind a metal ceiling light with a terribly low connection.

21:34:15 MQT: tele/Sonoff-9215/STATE = {"Time":"2018-12-09T21:34:15","Uptime":"2T20:16:58","Vcc":3.138,"POWER":"OFF","Wifi":{"AP":1,"SSId":"Wan17","BSSId":"FC:EC:DA:AA:1C:24","Channel":6,"RSSI":44}}
21:39:15 MQT: tele/Sonoff-9215/STATE = {"Time":"2018-12-09T21:39:15","Uptime":"2T20:21:58","Vcc":3.140,"POWER":"OFF","Wifi":{"AP":1,"SSId":"Wan17","BSSId":"FC:EC:DA:AA:1C:24","Channel":6,"RSSI":44}}
21:44:15 MQT: tele/Sonoff-9215/STATE = {"Time":"2018-12-09T21:44:15","Uptime":"2T20:26:58","Vcc":3.153,"POWER":"OFF","Wifi":{"AP":1,"SSId":"Wan17","BSSId":"FC:EC:DA:AA:1C:24","Channel":6,"RSSI":44}}
21:49:15 MQT: tele/Sonoff-9215/STATE = {"Time":"2018-12-09T21:49:15","Uptime":"2T20:31:58","Vcc":3.140,"POWER":"OFF","Wifi":{"AP":1,"SSId":"Wan17","BSSId":"FC:EC:DA:AA:1C:24","Channel":6,"RSSI":42}}
21:54:15 MQT: tele/Sonoff-9215/STATE = {"Time":"2018-12-09T21:54:15","Uptime":"2T20:36:58","Vcc":3.140,"POWER":"OFF","Wifi":{"AP":1,"SSId":"Wan17","BSSId":"FC:EC:DA:AA:1C:24","Channel":6,"RSSI":42}}
21:59:15 MQT: tele/Sonoff-9215/STATE = {"Time":"2018-12-09T21:59:15","Uptime":"2T20:41:58","Vcc":3.153,"POWER":"OFF","Wifi":{"AP":1,"SSId":"Wan17","BSSId":"FC:EC:DA:AA:1C:24","Channel":6,"RSSI":42}}

I had a sonoff sv that was randomly dropping it’s settings last week and reverting to WiFi manager if I let it ‘idle’ for 10 minutes, all gone again SSID etc)

I am not 100% sure which version I originally flashed but I ended up reflashing with 5.12 and then did an OTA upgrade to 6.30 - since then, zero issues.

It may also have been I was powering it up from the ‘plug’ I made up to flash them rather than powering it properly the first time so maybe a few spurious power cycles…

All I know is it’s working 100% now. Good luck!

I went two days with no problems at all, got home this afternoon and all gone nipple high again!

Reflashed this yesterday, woke up this morning to this:

The module is still setup correctly.:

but looks a little wide:

the log does contain this:

00:00:00 APP: Set Baudrate to 19200
00:00:00 Project sonoff RF_Bridge (Topic RF_Bridge, Fallback RF_Bridge, GroupTopic sonoffs) Version 6.3.0-2_3_0
00:00:00 WIF: Connecting to AP1 Wan17 in mode 11N as RF_Bridge...
00:00:06 WIF: Connected
00:00:06 DNS: Attempting connection...
00:00:06 HTP: Web server active on RF_Bridge with IP address
00:00:07 DNS: Attempting connection...
00:00:07 MQT: Attempting connection...
00:00:07 MQT: Connected
00:00:07 MQT: tele/RF_Bridge/LWT = Online (retained)
00:00:07 MQT: cmnd/RF_Bridge/POWER = 
00:00:07 MQT: tele/RF_Bridge/INFO1 = {"Module":"Sonoff Bridge","Version":"6.3.0","FallbackTopic":"RF_Bridge","GroupTopic":"sonoffs"}
00:00:07 MQT: tele/RF_Bridge/INFO2 = {"WebServerMode":"Admin","Hostname":"RF_Bridge","IPAddress":""}
00:00:08 MQT: tele/RF_Bridge/INFO3 = {"RestartReason":"Fatal exception:28 flag:2 (EXCEPTION) epc1:0x4000e1e0 epc2:0x00000000 epc3:0x00000000 excvaddr:0x00000000 depc:0x00000000"}
00:00:08 DNS: Attempting connection...
00:00:09 DNS: Attempting connection...
00:00:10 DNS: Att

I’ve just updated to and setup the device again after running the command: reset 5

Just need to wait and see what happens now.

This issue seems to be related to a smart GU10 bulb, when it is connected, (about 8ft away) after a short time the RF bridge gets screwed up, however if the bulb is not connected, i have not issues. The bulb was flashed with tasmota, and setup as an AI light. I do get alot of ghost switching with this bulb too! Connecting cables to the this is pretty easy to flash, i’m just annoyed as i have about ten of these I purchased to to setup in my house!

Hmm… those bulbs look interesting, if a little expensive…
Most of my lights here are dimmable GU10 and I have been looking for a ‘smart’ solution that doesn’t involve being an electrician.

Please post here if you ever solve this issue - or find the root cause.