Sonoff RF Bridge - different buttons show same code


I’ve been reading this post with great interest, since i am having the same issue:

In short: I’ve patched my R2 Sonoff RF Bridge with Tasmota 8.1.0. I have some old RF Plufgs (Sartano 2606). I can learn the buttons from the remote, and send the signals back using the buttons in the Tasmota web interface. But when i press the remote ON and OFF buttons, it shows the same code in the Tasmota console. Well, about the same, ‘Sync’ sometimes varies to 9910 or 9920, but never consistant.

Example of pressing the ON and OFF button.

ON : 15:22:39 MQT: tele/tasmota/RESULT = {“Time”:“2020-02-08T15:22:39”,“RfReceived”:{“Sync”:9900,“Low”:340,“High”:970,“Data”:“15555F”,“RfKey”:“None”}}
OFF : 15:22:57 MQT: tele/tasmota/RESULT = {“Time”:“2020-02-08T15:22:57”,“RfReceived”:{“Sync”:9900,“Low”:340,“High”:970,“Data”:“15555F”,“RfKey”:“None”}}

My question is : should i take the same path and re-flash my RF Bridge with Espurna, or is it possible to do something else to make it work with Tasmota?

The object is to create some switches in my HA Frontend to control my plugs, as well as integrate them with some automations.

Thanks in advance. :slight_smile:

1 Like

Just a thought, but are ON and OFF actually the same command? If you press ‘OFF’ when the device it controls is off, does it turn ON?

I could see some company reusing the same remote for many devices and just programming what each button does rather than casting a new mold and PCB for each device. Many devices use the same on/off code.

Good point, but unfortunately that is not the case. The OFF button only turns the plug off, and the ON turns it on. Neither of them is a toggle.

1 Like

Then you a remote that is not compatible with the sonoff RF Bridge. I have remotes that show the same code on the rf bridge, but work fine with a rflink.

You might be right about that. But as i wrote, the Sonoff can learn the codes just fine, and it can send them without problems. Right now i’ve learned 6 buttons, 3 ON and 3 OFF to button 1-6 on the web interface. It’s just in the console it doesn’t tell them apart. Pretty strange.

Well, i ended up flashing my Sonof RF Bridge with Espurna, and voila! The codes are interpreted correctly. I can now control my devices using the Sonoff RF Bridge.

So… if anyone has trouble getting the codes to work with Tasmota, i can recommend Espurna. :slightly_smiling_face: :+1:

1 Like

For Espurna, did you need to make the hardware modification ?

No, it wasn’t necessary in my case. I wasn’t sure, so i took the chance, and it worked. :slight_smile:

Thanks, maybe i’ll try espurna on one of my rfbridges.

Good luck with that. :slight_smile: