Sonoff S31 Over the Air Tasmota Flashing

I just received my Sonoff S31, tried to flash it with the Tasmota OTA, I’m using the sonota.exe program, and when I go to connect to the sonoff wifi. the command prompt disappears, so I don’t know if it threw an error or not. Is the S31 supported for OTA? And has anyone else done OTA Flashing of the S31? I’ve searched for information, and have tried a few things, still nothing.


This might help… what version of firmware does it have? if it’s 1.6 you maybe need to update to v2 first…

From my understanding you can not OTA the S31, until you have manually installed Tasmota. After that you should be good to go. It is pretty easy to take apart and flash.

That’s what I was afraid of. Looks like I will need to buy the serial adapter, so I can flash it.

Yeah, OTA flashing will only work once a custom firmware (Tasmota, ESPEasy, Etc.) is flashed to it I’m pretty sure.

To give you some words of encouragement, I’ve flashed just over a dozen S31’s at this point, and it’s not too bad. Dead easy once you get the hang of it, but not terribly difficult for a beginner either.

So that video IS showing an initial flash of Tasmota over-the-air… Starting with the Ewelink app and the stock iTead firmware. The requirement seems to be that you have a compatible initial firmware version.

The example in the video has nothing to do with needing a custom firmware.

I found the video in my post here the easiest way for me to flash the S31s:

Thanks everyone for the help. I ended up using the usb to serial board and flashing with esptool, got it up and running now.

Thanks again

Hi all, saw this thread. I was excited to get my 2 sonoff s31s today and fear I screwed them up. First some questions:

When I power them up and hold the button to put in programming mode is there any led or indicator showings its in the programming mode?

Second does anyone know if the two pads near ground do anything? THey are labeled TX and RX but I cant get it to work.

I’ve some destroyed one of RX pads on both of my devices after too much back and forth troubleshooting and using too hot of soldering iron.

Any help is greatly appreciated.

These are the only pins you need to connect. The other two are not needed.

Whenever I flash a Sonoff device I always attach a pinheader to it so if I need to flash it (not OTA) again the pins are already there and there’s less chance of damaging the pads. This is what I do for the S31’s.

1 Like

Thanks, I know the other two are not needed, but can they be used since I destroyed the pad on one of the TX?

Also, can you confirm, when going into program mode is there any visual indicator (led?) confirming its in program mode?

No, I wouldnt not think so. Looking at the traces on the back-side of the board those pads do not join up with the original TX/RX pads and run off to a different place. There is also no continuity between the two TXs, same for the two RXs.

The VIAs for the correct Rx & Tx are right on the other side of the board though, so you should be able to just scrape off the solder mask and attach a wire to it there.

Thanks sorry for repeating but before I ruin another one, what is the situation with the leds when going into the program mode? Is there any indication?

Neither of the LEDs lights at all when you come up in programming mode.