Sonoff SNZB-02 temp/humidity sensor disconnects

Tags: #<Tag:0x00007fc421009758>

I bought a couple of the Sonoff SNZB-02 temp and humidity Zigbee sensors, which I’m connecting to with a Conbee II. These suited me well as I was looking for something with a battery that I could put in my wine fridge to monitor temps.

This all worked well for a while and then I noticed two things. First of all they seem to be quite unreliable connection wise - I’ve had to resync both of these a couple of times. The Conbee II is about a metre away from both of these (one is a test and the other is in the fridge) so it’s not a signal/distance thing.

Also - after 2-3 weeks of using both of these the battery on both is sitting around 50%. I thought these were supposed to last quite a while…?

So are these just not very good and I should look at another type/brand of sensor?

Hi,
I think this might be because of the Conbee or a faulty device because I have a SNZB-02 too and it works fine but I use the Sonoff ZB Bridge.
After a few weeks I’m still at 100% battery.
Cheers,

The one in the fridge will probably discharge faster due to the low temps. But 50% after 2-3 weeks is really bad. Mine are running for 6-7 weeks now and the lowest is at 95% in the bathroom and it’s logical that this one discharges the most as it sends more reports due to humidity changing a lot in the bathroom (showering, taking a bath etc.).

Is thr ConBee connectrd to a USB 3 port? Are you using a extension cord to put the ConBee away from the device it is attached to? Are you using different channels for your WiFi and ZigBee?

1 Like

All good questions, so no - it’s in a USB 2.0 - should it be in 3.0?

No extension cord, I did see that suggested somewhere I can’t believe I forgot about trying that.

Haven’t looked at the channels yet either as they are right next to each other I didn’t think it would matter. Does ZHA allow me to see/change channels or do I need to start looking at zigbee2mqtt, I haven’t given it a go yet.

1 Like

No, USB 2.0 is fine, however USB 3.0 can lead to interference with the ZigBee stick.

Please try that, it often solves stability issues and it’s cheap to test.

Most people use something low for WiFi 1-6 and something high for zigbee above 11. Channels next to each other are overlapping as far as I know and can lead to issues.

Don’t know, I’m using deconz.

2 Likes

That’s already made a huge difference, thanks mate. I haven’t changed channels yet but an extension cable to get it away from the PC seems to have done the trick. Both batteries have gone back up so I’m wondering if was struggling to report properly in the first place. It probably has chewed through battery before so I’ll look at replacing them soon to see how the life goes.

Now I need to figure out my options for a zigbee repeater here in Australia as the devices don’t seem to reach up to the top level of my place.

I use home assistant, combee ii/deconze on a pie and several agara sensors in my house and was wondering about the reporting state of the Sonoff versions.
My temp sensors work fine and happy with the reporting time a but the motion sensors kind of suck as far as the reset time.
Battery life has been great about 7 months over 90% battery life on door, motion, vibration and temperature sensors including a vibration sensor in a fridge.
Need to set up several sensors at another home
Debating using a sonnof usb zigbee dongle and Sonoff sensors.
My question what is the feedback of people using for some time
And how is the reporting state and battery life working out

2 Likes

I’ve been seeing Sonoff SNZB-02 temp sensors go stupid and disconnect on me in the last 2 months, even though signal strength was still good (within 10-15 feet of the Sonoff ZB Bridge!!).
temp2 iffy connection temp2 iffy graph

When the sensors became unreliable and iffy, their Power reading was down near 50%, even though their batteries were not low (measured with a battery tester, set for 3V lithium batteries)!
patio temp sensor temp3 iffy connection

When the sensors came disconnected, I rescanned for them (and pushed their pairing button) and they reconnected…in an iffy working fashion. They would report temperature for a while then stop again.

I tried various things to try and make them more reliable.

  1. added new batteries…didn’t help…Upon rescan/reconnect, power reading was still around 50%…something is fishy!!
  2. re-soldered the battery terminal connections on the PCB…didn’t help…power reading was still around 50% and there was still iffy connection and temperature reporting.

I found that I had to REMOVE them via Home Assistant, and then use the Home Assistant Zigbee Bridge controls to rescan and add them back. After that, they behaved for a week or 2.
The fact that removing them from HA and then, rescanning and re-adding them made a significant reliability difference suggests a software problem, rather than a hardware problem.

I sniffed my Zigbee network
how-to: https://www.zigbee2mqtt.io/how_tos/how_to_sniff_zigbee_traffic.html
and found it was operating on Zigbee ch.11 (inside of wifi ch.1).
I just took the step of moving my home wifi AP to wifi ch.11 to get it away from the lower numbered Zigbee channels.
I’ll report back on the reliability of the Sonoff temperature sensors with this change.

1 Like

I would like to also report my experience with the Sonoff Zigbee environment.

A month or so ago I received a full set including a Sonoff Zigbee Bridge, a TH sensor, a PIR, a Wireless Button and a Door Sensor. Flashed the Zigbee Bridge with the latest firmware and tasmota, paired it in ZHA and paired all the sensors.
Things looked very good for the first few days, after which I started having issues with the PIR and the TH sensors. False positives and disconnects, reportings of very low battery, unavailability were the main ones. Tried other batteries, deleted them from HA and repaired them fixed the issue for a couple of days but then the same all over again. The door sensor and button work flawlessly. Also in the HA logs I can see frequent UART errors which is most probably the Zigbee Bridge disconnecting and reconnecting on WiFi and disrupting the serial flow of data. Image attached from the battery level going up again after it went down to 30% (3 weeks in)

Since moving my wifi accesss point to wifi ch.11 yesterday (to get it away from the Zigbee Bridge on Zigbee ch.11), another sensor disconnected overnight.
So, the disconnects don’t appear connected with wifi interference.
Temp2 disconnected 4am 12-20-2020

After removing this Temp2 sensor from HA, and rescanning for it, it got re-added.
Look at the insane drop in battery power (Voltage)!
Temp2 shows wild voltage swings 12-20-2020

How does a micro power sensor go from 100% down to 40%, overnight???
Can we trust the power metering in these devices?
When I remove the batteries at test them with the appropriate 3V lithium setting on the battery tester, they show they have a charge in the green, good range!

1 Like

I’ve been using a couple of these for a couple of weeks now using a cheap CC2531 adapter on Zigbee2MQTT with no issues whatsoever, both still report 100% battery too

I know it’s not much help but thought the information may be useful in some way…

Last night I put a new battery into the sensor I am calling Temp2.
I rescanned (without removing it from the HA devices list) and it showed 100% battery.

When I checked it this morning, I discovered that it didn’t stay connected very long!
There were no more reports from the Temp2 sensor after the re-scan step.

So, I did another device re-scan (without removing it from the HA devices list) and it reconnected with a battery percentage of 47%! WHAT?? It’s a new battery!!
image (1)

Next, I tried removing the Temp2 device from the HA devices list and then doing a re-scan to add it back to the HA database. After doing that, the battery was reported at 100% again.
image (2)

There’s something significant that happens when you remove the device from the HA database, and re-add it!
Results like this point to a software/firmware problem rather than a hardware problem.

1 Like

I’m running an HA x86_64 OVA virtual machine in VMware.
I’ve seen some python zigby-related error messages in the HA log
zigpy log errors

From the Terminal in the HA interface, I’m trying to locate python, zigpy and bellows.
They are supposed to be in the following locations but are NOT there!
/usr/local/lib/python3.8/
/usr/local/lib/python3.8/site-packages/zigpy/
/usr/local/lib/python3.8/site-packages/bellows/

Where are they??

I’ve had good success with a couple of the Sonoff SNZB-02 sensors, but a third one is not measuring the temperature (just sends 0). They’re so cheap I hardly care. I’ve got a slightly more expensive AQara device arriving soon which does air pressure as well, I wonder if that will prove more reliable.

Update: The Sonoff sensor is now working properly after a couple of resets. The AQara sensor - WSDCGQ11M - arrived, and is working well. It’s a physically smaller, neater looking unit than the Sonoff (and it comes in a much larger box), with a smaller capacity battery (CR2032 vs CR 2450). deCONZ/Phoscon recognises it as a Xiaomi multi-sensor, so Home Assistant is happy with it.

I updated Home Assistant to the latest version (2020.12.2) on Dec.24, and the disconnections of the SNZB-02 sensors stopped.
I’m crossing my fingers that the the update was the fix!
I will keep watching for disconnections…

I don’t think so. I have two SNZB 02 and the latest version of HA, and one disconnect earlier this week, the other disconnected yesterday…
I’m waiting to receive my Conbee II stick to try with Deconz or Zigbee2Mqtt instead of ZHA with the Sonoff ZBBridge

DOH! I had a disconnection of my Temp2 sensor overnight.
Yesterday, I was altering the configuration of my Zigbee network by adding a Sonoff S31 Zigbee outlet, with the desire to have it be a repeater for the Temp2 sensor.

After pairing the Sonoff S31 outlet with the Sonoff Zigbee Bridge, it didn’t appear to be automatically providing repeater support for the Temp2 sensor. ZHA_MAP diagrams were my evidence of this.
image

So, I tried to manually pair the S31 with the Temp2 sensor, and it appeared to be functioning as a repeater with a strong signal connection between the S31 and Temp2.
S31 repeating Temp sensor

But, this morning, the Temp2 sensor was disconnected AGAIN, so I don’t know what went wrong.
It sure appears that Zigbee just barely works. :roll_eyes:

Having the same issues with a SNZB-02 and the sonoff zigbee bridge flashed with tasmota.
It happens every few days to once in like 2 weeks. I’m not sure how zigbee works, but i’d think that if one of the reports by the temp sensor gets missed by the gateway because some interferance or range issue, it would be able to pick up later reports again. It seems that once it fails, it doesn’t get any reports from then sensor at all anymore, even when you place the sensor next to the zigbee bridge.
This seems weird to me as they don’t have a constant connection, and it’s not like the connection has been dropped or someting.

EDIT: I also have a lidl led bulb that is connected to the sonoff zigbee bridge, and this never loses the connection, even when the power to the bulb gets cut, and later gets powered on again it reconencts to the gateway just fine.

2 weeks ago I added an IKEA TRADFRI repeater to the ZB network and within 5 minutes it paired itself with temperature sensors and started repeating their signals back to the Sonoff Zigbee Bridge!

The whole ZB newtork performance improved after adding just 1 of the TRADFRI repeaters!
Even the Sonoff S31 started automatically pairing itself with nearby temperature sensors shortly after adding the TRADFRI repeater.
Until the TRADFRI showed up, the S31 had been acting like a slug - not automatically pairing and repeating. To anthropomorphize, it’s like the S31 saw there was competition, and so it started behaving like it should have, all along! :laughing:

The other benefit I’ve observed, none of the Sonoff temperature sensors have disconnected since the addition of a TRADFRI repeater!

I just added another TRADFRI repeater this morning, and I’m watching hour to hour as temperature sensors re-pair themselves with the new TRADFRI.