Sonoff TH16 sensor problem

Hi guys I’m a complete NOOB to all of this.
Before I flashed the TH16 it showed the temp and hum in the “ewelink” app, but after the flash it does not show temp/hum in the Tasmota web interface. Do I need to configure it first in the interface?

No it should show up, try resetting the module to a basic one first and then back to a TH model. (If you use home assistant autodiscovery you will have to reset it to basic module first anyways).

Also did you check if your sensor is configured in the module settings? It should be assigned to one of the gpio’s.

Thanks will try that. My HA does not have the “autodiscovery” option in “Integrations”

No luck at all. downgrade to 6.4.1,upgrade to 6.5.0 then 6.6.0 without any luck. Maybe the sensor is faulty.

Hm no wait, I should have been more detailed. Home Assistant has discovery as default. This means that it will always try to discover your devices regardless of platform (as long as HA supports it natively or through the means of a custom component).

Do you want to use your tasmota devices with MQTT? That is probably the most common scenario. What you need to do to get your devices discovered is to configure the mqtt integration in HA and then on your tasmota device you will need to set it to a basic module first. Then go to the console and type SetOption19 on This will enable Home Assistant autodiscovery on your tasmota device. Now make sure you have configured mqtt on your tasmota device as well. LAST, set the module type to the type belonging to your device. If you have a Sonoff TH model, choose that from the drop down menu. NEVER start with setting the module, always make sure you have done SetOptions19 on FIRST or autodiscovery will NOT work. So do the module type as last. If you failed to do so you can always set it back to a basic module and start over again.

Ok, so now to your actual question of the sensor. You say it is not working right? So first off, what kind of sensor do you use? For example I use a AM2301. You will have to set this in the settings. Make sure it says TH in the title of the page. (Seems you already got this)

Second make sure you have the sensor selected like this:

Make sure you select the right sensor on the GPIO14 dropdown menu.
Restart your tasmota device.

If all went well you should have a working device. If it went wrong I guess you will have to try another sensor to make sure the sensor is faulty. If that doesn’t work either your device might be faulty and you should send it back.

I hope this information will be of use to you.


Thanks will try that and post an update.

Amazing Jim! It works for me. Strange thing is my temperaature sensor has been working for 2 weeks since install and all of a sudden it stopped displaying temperature. I never had to set it to Basic in the beginning. Thanks again!

Has been a long time since I have used tasmota, but when I still used it this option was off by default.

Glad it worked for you!